|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- iSCSI Target daemon
iscsitgtd [-c config_file] [-d door_file]
The iscsitgtd daemon process implements the iSCSI configuration, control, and data paths, providing iSCSI Target Mode support in the Solaris operating system.
The configuration and control path is by means of the Solaris Doors subsystem (see door_create(3DOOR)), and provides the interface between the iSCSI Target administration utility, iscsitadm(1M), persistence configuration data stored in /etc/iscsi/target_config.xml and the operational state of the daemon process itself.
The data path, managed by the daemon, exists between TPC/IP port 3260, and the files, block devices, or raw SCSI devices configured as iSCSI target LUNs.
The following options are supported:
Override the location of the persistence configuration data from /etc/iscsi/target_config.xml to a file location of one's choosing.
Override the location of the Solaris Door used for configuration from /var/run/iscsi_tgt_door to a door of one's choosing.
Persistent configuration data.
See attributes(5) for descriptions of the following attributes:
The iSCSI Target daemon, iscsitgtd, is managed by the service management facility, smf(5), under the fault management resource identifier: