|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- set up a virtual FTP host
ftpaddhost -c | -l [-b] [-x xferlog] hostname root_dir
The ftpaddhost script is executed by the super user to set up virtual FTP hosts. The ftpaddhost command configures the virtual host hostname under directory root_dir. The value of hostname can be an IP address or the name of a host.
The ftpaddhost script supports the following options:
Create a banner for the virtual host. This option is useful to confirm that the virtual host is working.
Configure complete virtual hosting. This option allows each virtual host to have its own version of the ftpaccess, ftpconversions, ftpgroups, ftphosts, and ftpusers files. The master version of each of these configuration files is copied from the /etc/ftpd directory and placed in the /etc/ftpd/virtual-ftpd/hostname directory. If the /etc/ftpusers file exists it is appended to the virtual ftpusers file. If a virtual host lacks its own version of a configuration file, the master version is used.
Configure limited virtual hosting. This option allows a small number of parameters to be configured differently for a virtual host. See the virtual keyword on the ftpaccess(4) manual page.
Create a logfile entry such that the transfer logs for the virtual host are written to the specified file. An absolute path must be specified for the xferlog file.
The following operands are supported:
The host name or IP address of the virtual server.
The absolute pathname of the directory under which the virtual server is set up.
The following exit values are returned:
Improper usage of the command
The configuration files directory for the virtual host hostname.
See attributes(5) for descriptions of the following attributes: