|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- graphical interface for managing DHCP service
dhcpmgr is a graphical user interface which enables you to manage the Dynamic Host Configuration Protocol (DHCP) service on the local system. It performs the functions of the dhcpconfig, dhtadm, and pntadm command line utilities. You must be root to use dhcpmgr. The dhcpmgr Help, available from the Help menu, contains detailed information about using the tool.
You can perform the following tasks using dhcpmgr:
Use dhcpmgr to configure the DHCP daemon as a DHCP server, and select the data store to use for storing network configuration tables..
Use dhcpmgr to configure the DHCP daemon as a BOOTP relay.
Use dhcpmgr to start, stop, enable, disable or unconfigure the DHCP service or BOOTP relay service, or change DHCP server parameters.
Use dhcpmgr to add, modify, or delete IP addresses leased by the DHCP service.
Use dhcpmgr to add, modify or delete macros used to supply configuration parameters to DHCP clients.
Use dhcpmgr to add, modify or delete options used to define parameters deliverable through DHCP.
Use dhcpmgr to configure the DHCP server to use a different data store, and convert the DHCP data to the format used by the new data store.
Use dhcpmgr to export data from one Solaris DHCP server and import data onto another Solaris DHCP server.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes: