|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- Sun Solstice Enterprise DMI Service Provider
/usr/lib/dmi/dmispd [-h] [-c config-dir] [-d debug-level]
The DMI Service Provider, dmispd, is the core of the DMI solution. Management applications and Component instrumentations communicate with each other through the Service Provider. The Service Provider coordinates and arbitrates requests from the management application to the specified component instrumentations. The Service Provider handles runtime management of the Component Interface (CI) and the Management Interface (MI), including component installation, registration at the MI and CI level, request serialization and synchronization, event handling for CI, and general flow control and housekeeping.
The Service Provider is invoked from a start-up script at boot time only if contents of the DMI Service Provider configuration file /etc/dmi/conf/dmispd.conf are non-trivial.
The following options are supported:
Specify the full path of the directory containing the dmispd.conf configuration file. The default directory is /etc/dmi/conf.
Debug. Levels from 0 to 5 are supported, giving various levels of debug information. The default is 0, meaning no debug information is given.
If this option is omitted, then dmispd is run as a daemon process.
Help. Print the command line usage.
The following error values are returned:
An error occurred.
DMI Service Provider configuration file
See attributes(5) for descriptions of the following attributes: