|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- list available NFS resources from remote systems
dfshares [-F nfs] [-h] [server]...
dfshares provides information about resources available to the host through NFS. The -F flag may be omitted if NFS is the first file system type listed in the file /etc/dfs/fstypes.
The query may be restricted to the output of resources available from one or more servers.
dfshares without arguments displays all resources shared on the local system, regardless of file system type.
Specifying server displays information about the resources shared by each server. Server can be any system on the network. If no server is specified, then server is assumed to be the local system.
The output of dfshares consists of an optional header line (suppressed with the -h flag) followed by a list of lines containing whitespace-separated fields. For each resource, the fields are:
resource server access transport
Specifies the resource name that must be given to the mount(1M) command.
Specifies the system that is making the resource available.
Specifies the access permissions granted to the client systems; however, dfshares cannot determine this information for an NFS resource and populates the field with a hyphen (-).
Specifies the transport provider over which the resource is shared; however, dfshares cannot determine this information for an NFS resource and populates the field with a hyphen (-).
A field may be null. Each null field is indicated by a hyphen (-) unless the remainder of the fields on the line are also null; in which case, the hyphen may be omitted.
Specify the NFS file system type
Suppress header line in output.
See attributes(5) for descriptions of the following attributes: