|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 1/13 Information Library|
- perform asynchronous physical I/O
#include <sys/types.h> #include <sys/buf.h> #include <sys/uio.h> #include <sys/aio_req.h> #include <sys/ddi.h> #include <sys/sunddi.h> int aphysio(int (*strat)( struct buf *), int (*cancel)(struct buf *), dev_t dev, int rw, void (*mincnt)(struct buf *), struct aio_req *aio_reqp);
Pointer to device strategy routine.
Pointer to driver cancel routine. Used to cancel a submitted request. The driver must pass the address of the function anocancel(9F) because cancellation is not supported.
The device number.
Read/write flag. This is either B_READ when reading from the device or B_WRITE when writing to the device.
Routine which bounds the maximum transfer unit size.
Pointer to the aio_req(9S) structure which describes the user I/O request.
Solaris DDI specific (Solaris DDI).
aphysio() performs asynchronous I/O operations between the device and the address space described by aio_reqp→aio_uio.
Prior to the start of the transfer, aphysio() verifies the requested operation is valid. It then locks the pages involved in the I/O transfer so they can not be paged out. The device strategy routine, strat, is then called one or more times to perform the physical I/O operations. aphysio() does not wait for each transfer to complete, but returns as soon as the necessary requests have been made.
aphysio() calls mincnt to bound the maximum transfer unit size to a sensible default for the device and the system. Drivers which do not provide their own local mincnt routine should call aphysio() with minphys(9F). minphys(9F) is the system mincnt routine. minphys(9F) ensures the transfer size does not exceed any system limits.
If a driver supplies a local mincnt routine, this routine should perform the following actions:
If bp→b_bcount exceeds a device limit, physio() returns ENOTSUP.
aphysio() can be called from user context only.
It is the driver's responsibility to call biodone(9F) when the transfer is complete.
Cancellation is not supported in this release. The address of the function anocancel(9F) must be used as the cancel argument.