|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 1/13 Information Library|
- free a raw buffer header
#include <sys/buf.h> #include <sys/ddi.h> void freerbuf(struct buf *bp);
Architecture independent level 1 (DDI/DKI).
Pointer to a previously allocated buffer header structure.
The freerbuf() function frees a raw buffer header previously allocated by getrbuf(9F). This function does not sleep and so may be called from an interrupt routine.
The freerbuf() function can be called from user, interrupt, or kernel context.