|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 1/13 Information Library|
- erase the contents of a buffer
#include <sys/types.h> #include <sys/buf.h> void clrbuf(struct buf *bp);
Architecture independent level 1 (DDI/DKI).
Pointer to the buf(9S) structure.
The clrbuf() function zeros a buffer and sets the b_resid member of the buf(9S) structure to 0. Zeros are placed in the buffer starting at bp→b_un.b_addr for a length of bp→b_bcount bytes. b_un.b_addr and b_bcount are members of the buf(9S) data structure.
The clrbuf() function can be called from user, interrupt, or kernel context.