|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 1/13 Information Library|
- Check for the existence of a property
#include <sys/sunldi.h> int ldi_prop_exists(ldi_handle_t lh, uint_t flags, char *name);
Solaris DDI specific (Solaris DDI)
Possible flag values are some combination of:
Match the lookup request independent of the actual dev_t value that was used when the property was created. The flag indicates any dev_t value (including DDI_DEV_T_NONE) associated with a possible property match satisfies the matching criteria.
Do not pass request to parent device information node if the property is not found.
Do not look at PROM properties (ignored on platforms that do not support PROM properties).
String containing the name of the property.
ldi_prop_exists() checks for the existence of a property associated with a device represented by the layered driver handle, regardless of the property value data type.
Properties are searched for based on the dip and dev_t values associated with the layered handle, and the property name. This association is handled by the layered driver infrastructure on behalf of the consumers of ldi_prop_exists().
The property search order is as follows:
Search software-properties created by the driver.
Search the software properties created by the system (or nexus nodes in the device info tree).
Search the driver global properties list.
If DDI_PROP_NOTPROM is not set, search the PROM properties (if they exist).
If DDI_PROP_DONTPASS is not set, pass this request to the parent device information node of the device represented by the layered handle.
Return 0 if not found and 1 if found.
Typically, the specific dev_t value associated with the device represented by the layered handle (ldi_handle_t) is used as a part of the property match criteria. This association is handled by the layered driver infrastructure on behalf of the consumers of the ldi property look up functions.
However, if the LDI_DEV_T_ANY flag is used, the ldi property lookup functions will match the request regardless of the dev_t value associated with the property at the time of its creation. If a property was created with a dev_t set to DDI_DEV_T_NONE, the only way to look up this property is with the LDI_DEV_T_ANY flag. PROM properties are always created with a dev_t set to DDI_DEV_T_NONE.
name must always be set to the name of the property being looked up.
ldi_prop_exists() returns 1 if the property exists and 0 otherwise.
This function may be called from user or kernel context.
The following example demonstrates the use of ldi_prop_exists(). /* Determine the existence of the "interrupts" property */ ldi_prop_exists(lh, LDI_DEV_T_ANY|DDI_PROP_NOTPROM, "interrupts");
Writing Device Drivers