|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 1/13 Information Library|
- parse the Link Target tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_LINKTARGET(client_handle_t ch, tuple_t *tu, cistpl_linktarget_t *pt);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cistpl_linktarget_t structure which contains the parsed CISTPL_LINKTARGET tuple information upon return from this function.
This function parses the Link Target tuple, CISTPL_LINKTARGET, into a form usable by PCCard drivers.
The CISTPL_LINKTARGET tuple is used to verify that tuple chains other than the primary chain are valid. All secondary tuple chains are required to contain this tuple as the first tuple of the chain.
The structure members of cistpl_linktarget_t are:
uint32_t length; char tpltg_tag[CIS_MAX_TUPLE_DATA_LEN];
The fields are defined as follows:
This field indicates the number of bytes in tpltg_tag.
This field provides the Link Target tuple information.
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA