|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 1/13 Information Library|
- return first or next client
#include <sys/pccard.h> int32_t csx_GetFirstClient(get_firstnext_client_t *fnc);
int32_t csx_GetNextClient(get_firstnext_client_t *fnc);
Solaris DDI Specific (Solaris DDI)
Pointer to a get_firstnext_client_t structure.
The functions csx_GetFirstClient() and csx_GetNextClient() return information about the first or subsequent PC cards, respectively, that are installed in the system.
The structure members of get_firstnext_client_t are:
uint32_t Socket; /* socket number */ uint32_t Attributes; /* attributes */ client_handle_t client_handle; /* client handle */ uint32_t num_clients; /* number of clients */
The fields are defined as follows:
If the CS_GET_FIRSTNEXT_CLIENT_SOCKET_ONLY attribute is set, return information only on the PC card installed in this socket.
This field indicates the type of client. The field is bit-mapped; the following bits are defined:
Return information on all clients.
Return client information for the specified socket only.
The client handle of the PC card driver is returned in this field.
The number of clients is returned in this field.
Client handle is invalid.
Socket number is invalid.
No PC Card in socket.
PC Card driver does not handle the CS_EVENT_CLIENT_INFO event.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA