|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 1/13 Information Library|
- Issue a devmap request to a device
#include <sys/sunldi.h> int ldi_devmap(ldi_handle_t lh, devmap_cookie_t dhp, offset_t off, size_t len, size_t *maplen, uint_t model);
Opaque mapping handle used by the system to describe mapping.
User offset within the logical device memory at which mapping begins.
Mapping length (in bytes).
Pointer to length (in bytes) of validated mapping. (Less than or equal to len).
Data model type of current thread.
The ldi_devmap() function passes an devmap request to the device entry point for the device specified by the layered handle. This operation is supported for character devices.
The ldi_devmap() function returns 0 upon success. If a failure occurs before the request is passed to the device, possible return values are shown below. Otherwise any other error number may be returned by the device.
Invalid input parameters.
Operation is not supported for this device.
This function may be called from user or kernel context.