|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 1/13 Information Library|
- map a zoneid_t struture identifier to a netid_t structure
#include <sys/neti.h> netid_t net_zoneidtonetid(const zoneid_t zone);
Solaris DDI specific (Solaris DDI).
valid zoneid_t structure that refers to a running zone.
The net_zoneidtonetid() function maps the given zoneid_t structure (used to represent a zone that is currently running) into a netid_t structure that is associated with the IP instance supporting network functions for that zone.
The net_zoneidtonetid() function returns -1 if no mapping took place. Otherwise, it returns the netid_t structure currently used by the zoneid_t structure. For zones that are using a shared IP instance, the netid_t structure for the instance owned by the global zone is returned.
The net_zoneidtonetid() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: