|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 1/13 Information Library|
- allocate virtual address space
#include <sys/types.h> #include <sys/buf.h> void bp_mapin(struct buf *bp);
Architecture independent level 1 (DDI/DKI).
Pointer to the buffer header structure.
bp_mapin() is used to map virtual address space to a page list maintained by the buffer header during a paged- I/O request. bp_mapin() allocates system virtual address space, maps that space to the page list, and returns the starting address of the space in the bp->b_un.b_addr field of the buf(9S) structure. Virtual address space is then deallocated using the bp_mapout(9F) function.
If a null page list is encountered, bp_mapin() returns without allocating space and no mapping is performed.
bp_mapin() can be called from user and kernel contexts.