|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 1/13 Information Library|
- free a previously allocated SCSI DMA I/O buffer
#include <sys/scsi/scsi.h> void scsi_free_consistent_buf(struct buf *bp);
Solaris DDI specific (Solaris DDI).
Pointer to the buf(9S) structure.
The scsi_free_consistent_buf() function frees a buffer header and consistent data buffer that was previously allocated using scsi_alloc_consistent_buf(9F).
The scsi_free_consistent_buf() function can be called from user, interrupt, or kernel context.
If consistent memory is bound to a scsi_pkt(9S), the pkt should be destroyed before freeing the consistent memory.