|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Express 11/10|
- Low-level module for controllers based on Adaptec AIC-7870P and AIC-7880P SCSI chips
The adp module provides low-level interface routines between the common disk/tape I/O system and SCSI (Small Computer System Interface) controllers based on the Adaptec AIC-7870P and AIC-7880P SCSI chips. These controllers include the Adaptec AHA–2940, AHA–2940W, AHA–2940U, AHA–2940UW, AHA–3940, and AHA–3940W, as well as motherboards with embedded AIC-7870P and AIC-7880P SCSI chips.
Supported devices are AIC-7850, AIC-7860, AIC-7870, AIC-7880 and AIC-7895.
The adp module can be configured for disk and streaming tape support for one or more host adapter boards, each of which must be the sole initiator on a SCSI bus. Auto-configuration code determines if the adapter is present at the configured address and what types of devices are attached to the adapter.
The Plug N Play SCAM Support option is not supported.
To use the AHA-3940 or AHA-3940W adapters, the motherboard must have a BIOS that supports the DEC PCI-to-PCI Bridge chip on the host bus adapter.
User-level programs have exhibited problems on some PCI systems with an Adaptec AHA-2940 or AHA-2940W card and certain motherboards. If problems with user-level programs occur, use the BIOS setup to disable write-back CPU caching (or all caching if there is no control over the caching algorithm). The affected motherboards are:
If the AHA-2940 SCSI adapter does not recognize the Quantum Empire 1080S, HP 3323 SE or other SCSI disk drive, reduce the Synchronous Transfer rate on the Adaptec controller to 8 Mbps.
The AHA-3940 has been certified by Adaptec to work on specific systems; however, some testing has shown that the Solaris operating environment works properly in some of those systems and not in others.
Use the Adaptec configuration utility to perform the following steps:
Configure each SCSI device to have a unique SCSI ID, then using the adapter's Advanced Configuration Options setup menu, set the Plug N Play SCAM Support option to Disabled.
If there is more than one controller (or an embedded controller), try to use one IRQ per controller.
Enable bus mastering for the slots with your host bus adapters, when the choice is given.
For older disk drives, tape drives, and most CD-ROM devices, make sure the maximum SCSI data transfer speed is set to 5.0 Mbps.
Enable support for disks larger than 1 Gbyte if applicable.
Configuration file for the adp driver; there are no user-configurable options in this file
See attributes(5) for descriptions of the following attributes:
Solaris (Intel Platform Edition) Hardware Compatibility List
Throughout the release, support of additional devices may be added. See the Solaris (Intel Platform Edition) Hardware Compatibility List for additional information.
The adp driver supports Logical Unit Number (“LUN”) values of 0 through 15. This range exceeds the standard SCSI-2 requirements which call for support of LUNs 0 through 7.