|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Express 11/10|
- ADMtek Fast Ethernet device driver
The afe driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface dlpi(7P) on ADMtek (now Infineon) Centaur and Comet Fast Ethernet controllers.
The afe driver can be used as either a "style 1" or a "style 2" Data Link Service Provider. Physical points of attachment (PPAs) are interpreted as the instance number of the afe controller as assigned by the Solaris operating environment.
The relevant fields returned as part of a DL_INFO_ACK response are:
Maximum SDU is 1500.
Minimum SDU is 0.
The dlsap address length is 8.
MAC type is DL_ETHER.
SAP length is -2. The 6–byte physical address is followed immediately by a 2–byte SAP.
Service mode is DL_CLDLS.
Broadcast address is the 6-byte Ethernet broadcast address (ff:ff:ff:ff:ff:ff).
If the SAP provided is zero, then IEEE 802.3 mode is assumed and outbound frames will have the frame payload length written into the type field. Likewise, inbound frames with a SAP between zero and 1500 are interpreted as IEEE 802.3 frames and delivered to any streams that are bound to SAP zero (the 802.3 SAP).
Enables (default) or disables IEEE 802.3u auto-negotiation of link speed and duplex settings. If enabled, the device negotiates among the supported (and configured, see below) link options with the link partner. If disabled, at least one of the link options below must be specified. The driver selects the first enabled link option according to the IEEE 802.3u specified preferences.
Enables the 100 BaseT4 link option. (Note that most hardware does not support this unusual link style. Also, this uses two pairs of wires for data, rather than one.)
Enables the 100 Base TX full-duplex link option. (This is generally the fastest mode if both link partners support it. Most modern equipment supports this mode.)
Enables the 100 Base TX half-duplex link option. (Typically used when the link partner is a 100 Mbps hub.)
Enables the 10 Base-T full-duplex link option. (This less-frequently used mode is typically used when the link partner is a 10 Mbps switch.)
Enables the 10 Base-T half-duplex link option. (This is the fall-back when no other option is available. It is typically used when the link partner is a 10 Mbps hub or is an older network card.)
See attributes(5) for a description of the following attributes:
Special character device.
32-bit driver binary (x86).
64-bit driver binary (x86).
64-bit driver binary (SPARC).
IEEE 802.3 — Institute of Electrical and Electronics Engineers, 2002