|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Express 11/10|
- Crypto Accelerator device driver
The dca device driver is a multi-threaded, loadable hardware driver supporting Sun PCI-based (pci108e,5454) cryptographic accelerators, such as the Sun Crypto Accelerator 1000.
The dca driver requires the presence of Solaris Cryptographic Framework for applications and kernel clients to access the provided services.
The dca driver maintains the following statistics:
Total number of jobs submitted to the device for 3DES encryption.
Total number of bytes submitted to the device for 3DES encryption.
Total number of jobs submitted to the device for RSA public key operations.
Total number of jobs submitted to the device for RSA private key operations.
Total number of jobs submitted to the device for DSA signing.
Total number of jobs submitted to the device for DSA verification.
Total number of jobs submitted for pure entropy generation.
Total number of bytes of pure entropy requested from the device.
Total number of jobs submitted for entropy generation, with SHA-1 post-processing.
Total number of bytes of entropy requested from the device, with SHA-1 post-processing.
Additional statistics may be supplied for Sun support personnel, but are not useful to end users and are not documented here.
The dca driver can be configured by defining properties in /kernel/drv/dca.conf which override the default settings. The following properties are supported:
Disables the generation of statistics. This property may be used to help prevent traffic analysis, but this may inhibit support personnel.
Disables the SHA-1 post-processing of generated entropy. This may give "truer" random numbers, but it may also introduce the risk of external biases influencing the distribution of generated random numbers.
See attributes(5) for descriptions of the following attributes:
dca configuration file
64–bit ELF kernel driver (SPARC)
32–bit ELF kernel driver (x86)
64–bit ELF kernel driver (AMD64)
Solaris Cryptographic Framework.