|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Express 11/10|
- Device name file system
The dev filesystem manages the name spaces of devices under the Solaris operating environment. The global zone's instance of the dev filesystem is mounted during boot on /dev.
A subdirectory under /dev may have unique operational semantics. Most of the common device names under /dev are created automatically by devfsadm(1M). Others, such as /dev/pts, are dynamic and reflect the operational state of the system. You can manually generate device names for newly attached hardware by invoking devfsadm(1M) or implicitly, by indirectly causing a lookup or readdir operation in the filesystem to occur. For example, you can discover a disk that was attached when the system was powered down (and generate a name for that device) by invoking format(1M)).
Mount point for the /dev filesystem in the global zone.
The global /dev instance cannot be unmounted.