|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 8/11 Information Library|
- VIA VT823x (VT8233, VT8235, VT8237) south bridge audio digital controller interface
The VT823x device uses the VT823x south bridge audio digital controller and an AC-97 Codec to implement the audio device interface.
Applications that open /dev/audio can use the AUDIO_GETDEV ioctl(2) to determine which audio device is being used. The audiovia823x driver returns the string SUNW,audiovia823x in the name field of the audio_device structure. The version field contains the letter “a” and the config field contains the string onboard1.
Key to the above table: Ver = Version. Out = Line Out. H. P. = Head Phone. Spkr = Internal Speaker. In = Line In. Mic. = Microphone. CD = CD-ROM.
The VT823x device provides support for the internal speaker, headphone, line out, line in and microphone. The play.mod_ports and record.mod_ports fields of the audio_info structure (see audio(7I)) indicate which ports may be manipulated.
The configuration file /kernel/drv/audiovia823x.conf is used to configure the audiovia823x driver so that the audio mixer is enabled or disabled. See the mixer(7I) manual page for details. The audio mixer mode may be changed at any time using mixerctl(1). Note that some systems may not support sample rates other than 48K and the compatible mode may not work as expected. On such systems, the mixer mode is preferred.
The VT823x device supports 8-bit linear and 16-bit linear encodings in mono and stereo. With the mixer enabled, a continuous range of sample rates from 5510 to 48000 Hz is supported. With the mixer disabled, the following sample rates are supported: 5510, 6620, 8000, 9600, 11025, 16000, 18900, 22050, 27420, 32000, 33075, 37800, 4410, and 48000 Hz. The device can be opened for simultaneous playing and recording whether the mixer is enabled or not.
Because the VT823x device manipulates buffers of audio data, the reported input and output sample counts will vary at any given time from the actual sample count by no more than the size of the buffers the audiovia823x driver is transferring. In general, programs should not rely on the absolute accuracy of the play.samples and record.samples fields of the audio_info structure.
The driver determines the frequency of play and record interrupts. For playing audio, this determines how often and how much audio is requested from the audio mixer. The impact of interrupts on recording is minimal. However, if a very small read buffer size is set, the record interrupt rate should be increased to prevent the buffer from overflowing. The play and record interrupt rates are tunable in the /kernel/drv/audiovia823x.conf file.
audiovia823x errors are described in the audio(7I) man pages.
Symbolic link to the system's primary audio device. (Not necessarily a VT823x audio device).
Control device for the primary audio device.
Represents the first audio device on the system. (Not necessarily a audVT823x audio device).
Audio control for /dev/sound/0.
Audio sample files.
Audiovia823x driver configuration file.
See attributes(5) for descriptions of the following attributes:
VIA VT823x (VT8233, VT8235, VT8237) South Bridge Data Sheet
In addition to being logged, the following messages may appear on the system console:
The play interrupt rate specified in audiovia823x.conf is set too low. It is being reset to the rate specified in the message. Update audiovia823x.conf to a higher play interrupt rate.
The play interrupt rate specified in audiovia823x.conf is set too high. It is being reset to the rate specified in the message. Update audiovia823x.conf to a lower play interrupt rate.
The record interrupt rate specified in audiovia823xs.conf is set too low. It is being reset to the rate specified in the message. Update audiovia823x.conf to a higher record interrupt rate.
The record interrupt rate specified in audiovia823x.conf is set too high. It is being reset to the rate specified in the message. Update audiovia823x.conf to a lower record interrupt rate.