|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 8/11 Information Library|
- Solaris USB Architecture (USBA)
USB provides a low-cost means for attaching peripheral devices, including mass-storage devices, keyboards, mice, and printers, to a system. For complete information on the USB architecture, visit the USB website at http://www.usb.org.
USBA supports 126 hot-pluggable USB devices per USB bus. The maximum data transfer rate is 1.5 Mbits (low speed USB 1.x) or 12 Mbits (full speed USB 1.x) or 480 MBits (high speed USB 2.0) Mbits per second (Mbps).
USBA adheres to the Universal Serial Bus 2.0 specification and provides a transport layer abstraction to USB client drivers.
For information on how to write USB client drivers, see Writing Device Drivers. For the latest information on writing USB drivers, visit http://developers.sun.com/solaris/developer/support/driver/usb.html. For a complete list of USBA interfaces, see Intro(9F) and Intro(9S).
Devices without a driver may have a libusb(3LIB) application. For more information, see /usr/sfw/share/doc/libusb/libusb.txt.
Listed below are drivers and modules which either utilize or are utilized by USBA. Drivers in /kernel/drv are 32 bit drivers (x86 only). Drivers in /kernel/drv/sparcv9 or /kernel/drv/amd64 are 64 bit drivers.
See attributes(5) for a description of the following attributes:
cfgadm_usb(1M), libusb(3LIB), attributes(5), ehci(7D), hid(7D), hubd(7D), ohci(7D), scsa2usb(7D), uhci(7D), usb_ac(7D), usb_as(7D), usb_mid(7D), usbprn(7D), usbsacm(7D), usbser_edge(7D), usbsksp(7D), usbsprl(7D), ugen(7D), virtualkm(7D). Intro(9F), Intro(9S)
Writing Device Drivers
Universal Serial Bus Specification 2.0.
Interface Association Descriptor Engineering Change Notice (ECN)
System Administration Guide: Basic Administration
Booting from USB mass-storage devices is not supported on SPARC, but is supported on X86.
The messages described below may appear on the system console as well as being logged. All messages are formatted in the following manner:
WARNING: Error message...
The installed Solaris software does not contain a supported driver for this hardware. <number> is the interface number. <name> is either the device path name or the device name.
An internal error occured. Please reboot your system. If this problem persists, contact your system vendor.
The following messages may be logged into the system log. They are formatted in the following manner:
<device path><usba<instance number>): message...
Driver is incompatible with USBA framework.