Using Siebel Tools

What's New in This Release

Back to top

Using Siebel Tools

Overview of Using Siebel Tools

Roadmap for Setting Up and Using Siebel Tool

Process of Setting Up the Development Environment

Installing Siebel Tools

Specifying the Data Source That Siebel Tools Uses

Setting Database Options

Choosing the Browser That the Applet Layout Editor Uses

Controlling How Siebel Tools Handles Versions for a Workflow Process or Task UI

Setting the Language Mode

Controlling How Siebel Tools Displays the Confirmation Dialog Box

Resetting Development Tools Options

Using the Object Explorer and Object List Editor

Overview of the Object Explorer and Object List Editor

Locating and Modifying an Object Definition in the Object List Editor

Displaying Object Types in the Object Explorer

Using Lists and Tabs in the Object Explorer

Using the Object List Editor

Using Menus and Running Queries

Using the Menu Bar

Using a Right-Click Menu

Running Queries

Getting Documentation About an Object

Using Windows, Wizards, and Toolbars

Using the Properties Window

Using the Applets Window

Using the Controls and Columns Window

Using the Palettes Window

Using the Web Template Explorer Window

Using the Multi Value Property Window

Using the Bookmarks Window

Displaying, Docking, and Stacking Windows

Using a New Object Wizard

Using the Toolbars

Using Editors in Siebel Tools

Using a Layout Editor

Specifying the Web Template Editor

Using an Editor That Includes a Canvas

Using a Script Editor

Using the Command Line

Back to top

Managing Repositories

Overview of Managing Repositories

Viewing Information About the Current Repository

Renaming a Repository

Guidelines for Naming a Repository

Comparing Two Repository Files

Using the Server Manager Command Line Interface to Start the SRF Differences Utility

Managing Modifications That Multiple Developers Make

Administering Object Tags

Enabling Object Tagging in Siebel Tools

Tagging Objects

Tagging Objects That You Do Not Modify

Configuring Siebel CRM to Read Data From a Single Repository

Exporting and Importing a Repository

Overview of Exporting and Importing a Repository

Importing a Repository in a Windows Environment

Importing a Repository in a UNIX Environment

Exporting a Repository

Importing or Exporting a Repository at a Later Time

Upgrading a Repository

Identifying Conflicts That Occur During an Upgrade

Process of Migrating a Repository

Preparing to Migrate the Repository

Using the Database Configuration Wizard to Migrate a Repository

Updating Siebel Remote Databases

Migrating Nonrepository Configurations and Data

Using the Repository Import and Export Utility

Guidelines for Migrating a Repository

Deleting a Repository

Back to top

Checking Out and Checking In Projects and Objects

Overview of Check Out and Check In

About the Project Object Type

Guidelines for Check Out and Check In

Getting Projects from the Server Repository

Getting All Projects from the Server Repository

Getting Some Projects from the Server Repository

Getting Locale Data from the Server Repository

Using Check Out and Check In

Allowing Object Locking for a Project

Checking Out Projects from the Server Repository

Checking Out Objects from the Server Repository

Checking In Projects or Objects to the Server Repository

Locking a Project in the Local Repository

Locking an Object in the Local Repository

Unlocking a Project

Undoing Project Check Out

Preventing Object Check In and Check Out

Viewing Locked Objects in a Project

Viewing Differences Between the Local Repository and the Server Repository

Setting Options for Check Out and Check In

Configuring Third-Party Code Control

Configuring Siebel Tools to Restart Editors After Check Out

Customizing Projects

Creating a New Project

Renaming a Project

Modifying the Project That an Object References

Modifying the Location Where Siebel Tools Saves Objects and Projects

Back to top

Customizing Objects

Overview of Customizing Objects

Creating, Modifying, Copying, Validating, and Deleting an Object

Creating an Object

Modifying an Object

Copying an Object

Validating an Object

Deleting an Object

Examining Objects

Searching the Repository

Viewing Object Relationships

Comparing and Synchronizing Objects Between Repositories and Archives

Comparing Different Versions of a Workflow Process or Task UI

Determining When Siebel CRM Created or Updated a Record

Back to top

Using Siebel Script Editors

Using the Siebel Script Editor

Overview of Using Siebel Script Editors

Setting Options for the Script Editor

Opening the Siebel Script Editor

Using the ST eScript Engine

Overview of Using the ST eScript Engine

Enabling the ST eScript Engine

Setting Options for the ST eScript Engine

Opening the Script Assist Window

Using Fix and Go

Using Running Tool Tip

Using Script Libraries with the ST eScript Engine

Using the Siebel Debugger

Overview of Using the Siebel Debugger

Setting Debug Options

Accessing the Debugger

Validating Script Syntax

Using Breakpoints

Using the Calls Window

Using the Watch Window While it Monitors a Script

Tracing a Script

Using the Script Profiler

Overview of the Script Profiler

Enabling the Script Profiler and Line Profiler

Running the Script Profiler

Back to top

Localizing Strings and Locale Data

Configuring Symbolic Strings

Overview of Configuring Symbolic Strings

Modifying the Configuration File to Support Symbolic Strings

Creating a Project for Your Symbolic Strings

Modifying a Predefined Symbolic String

Creating a New Symbolic String

Modifying a Symbolic String to Globally Update Display Values

Setting a Symbolic String Reference

Entering a String Override

Converting Symbolic Strings

Consolidating Symbolic Strings

Using a Batch File to Convert Strings

Configuring Locale Data

Configuring Nontranslatable Locale Object Properties

Displaying Controls and List Columns According to Locale

Fixing Orphaned String References After an Upgrade

Using the Locale Management Utility

Finding Untranslated Text Strings

Finding Existing Translations

Finding Objects That the Locale Management Utility Modifies

Finding Objects Modified Since the Last Export

Exporting Text Strings and Locale Properties to a File

Importing Text Strings and Locale Properties

Modifying the Value in All Strings for a Language

Using the Command Line to Run the Locale Management Utility

Using Advanced Compile to Localize a Repository

Overview of Using Advanced Compile

Using Advanced Compile

Back to top

Compiling, Testing, and Troubleshooting Your Customizations

Compiling Your Modifications

Overview of Compiling

Compiling Projects

Compiling Objects

Using an Incremental Repository Upgrade Kit

Using the Command Line to Import, Export, or Compile Objects

Testing and Troubleshooting Your Modifications

Setting Debug Options to Open the Siebel Client

Recovering from a Failed Development Server

Back to top

Archiving Objects

Overview of Archiving Objects

Exporting to an Archive

Using the Command Line to Export an Archive

Exporting Modified Objects

Importing from an Archive

Preparing the Siebel Tools Environment to Import an Archive

Importing an Archive

Importing Multiple Archives

Using the Command Line to Import an Archive

Importing Modified Objects

Using the Review Conflicts and Actions Dialog Box of the Import Wizard

Using the Application Deployment Manager

Using a Hotfix to Deploy Fixes to the Production Environment

Using the Command Line to Export Objects to a Hotfix

Exporting Objects to a Mid-Level Release

Back to top

Reference Materials for Siebel Tools

Menus and Menu Items on the Menu Bar

File Menu

Edit Menu

View Menu

Screens Menu

Go Menu

Query Menu

Format Menu

Debug Menu

Tools Menu

Window Menu

Help Menu

Buttons on the Toolbars

Edit Toolbar

List Toolbar

History Toolbar

Debug Toolbar

Simulate Toolbar

Format Toolbar

WF/Task Editor Toolbar

Configuration Context Toolbar

Buttons in the Palettes Window

Dialog Boxes That Check In Projects and Objects

Elements of the Project Check Out Dialog Box

Elements of the Object Check Out Dialog Box

Elements of the Check In Dialog Box

Dialog Boxes That Validate Objects

Elements of the Validate Dialog Box

Elements of the Validation Options Dialog Box

Dialog Boxes That Compare Objects

Elements of the Compare Objects Dialog Box

Dialog Boxes That Set Development Options

Development Options for Project Check In and Project Check Out

Development Options for Visualization Views

Development Options for Scripting

Development Options for Debugging

Parameters That Convert Symbolic Strings

Parameters You Use with the Conversion Export Utility

Parameters You Use with the Conversion Import Utility

Back to top


Back to top

Using Siebel Tools Copyright © 2013, Oracle and/or its affiliates. All rights reserved. Legal Notices.