|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- report data links statistics
dlstat [-r | -t] [-Z] [-i interval] [-z zone[,...]] [link]
dlstat [-a | -A] [-Z] [-i interval] [-p] [ -o field[,...]] [-u R|K|M|G|T|P] [-z zone[,...]] [link]
dlstat show-phys [-r | -t] [-Z] [-i interval] [-a] [-p] [-o field[,...]] [-u R|K|M|G|T|P] [-z zone[,...]] [link]
dlstat show-link [-r | -t] [-Z] [-i interval] [-a] [-p] [-o field[,...]] [-u R|K|M|G|T|P] [-z zone[,...]] [link]
dlstat show-link -h [-Z] [-a] -f filename [-d] [-F format] [-s time] [-e time] [-z zone[,...]] [link]
dlstat show-aggr [-r | -t] [-Z] [-i interval] [-p] [-o field[,...]] [-u R|K|M|G|T|P] [-z zone[,...]] [link]
The dlstat command reports run time statistics about data links. dladm(1M) show-phys provides link-name information to dlstat show-phys. dladm(1M) show-link provides link-name information to dlstat show-link. dladm(1M) show-aggr provides link-aggregation information to dlstat show-aggr.
dlstat has the six forms of commands shown in the SYNOPSIS, above. The first two forms do not have subcommands, while the remaining forms do. All six forms are described under “Subcommands,” below.
The dlstat command has the following options and operands that are common (unless explicitly marked otherwise) among a number of command forms shown under “Subcommands,” below.
Dump all total statistics fields.
Specify an interval in seconds at which statistics are refreshed. The default interval is one second.
Display a case-insensitive, comma-separated list of output fields to display. The field name must be one of the fields listed below, or the special value all to display all supported fields.
List of supported RX fields:
intrs (only applicable without a subcommand or with show-link)
polls (only applicable without a subcommand or with show-link)
idrops (only applicable without a subcommand or with show-link)
List of TX side fields:
odrops (only applicable without a subcommand or with show-link)
For the show-phys subcommand, the index column identifies individual RX and TX hardware rings within a physical device. For the show-link subcommand, the index column identifies RX and TX hardware lanes within a data link. See Oracle Solaris Administration: Network Interfaces and Network Virtualization for an explanation of the difference between hardware rings and hardware lanes.
Display output in a stable, machine-parseable format.
Display receive-side statistics only. Includes bytes and packets received, hardware and software drops, and so forth. See “Examples” for complete listing.
Display transmit-side statistics only. Includes bytes and packets sent, drops, and so forth. See “Examples” for complete listing.
If used, allows choosing the unit in which to display all statistics, for example, R:raw count, K:Kilobits, M:Megabits, T:Terabits, P:Petabits. If not used, then different units, as appropriate, are used to display the statistics, using the format xy.zU, where x, y, and z are numbers and U is the appropriate unit.
Display ZONE column in the output.
Display the statistics only for links in the specified zone. By default, dlstat displays the statistics for links in all the zones when it is run from the global zone.
When run from a non-global zone, dlstat displays statistics only for links in that zone. A non-global zone cannot see links in other zones.
If specified, display the statistics only for the named link, physical device (for show-phys), or aggregation (for show-aggr). Otherwise, display statistics for all links, devices, or aggregations.
dlstat supports the following command forms.
Iteratively examine all links and report statistics. The output is sorted in descending order of link utilization. If no link is specified, the system displays statistics for all links. The traffic statistics are displayed per link and not per physical device. For example, for a VNIC configured on a physical link, traffic flowing through that VNIC is not reflected in the statistics for the underlying physical link. However, the link statistics will include traffic that matches user-defined flows configured on top of that link.
This command form has one option that is not described under “Options,” above:
Dump all statistics fields for this data-link. Output statistics of this command are inclusive of all the statistics reported by all other dlstat commands.
Allows specifying which statistics to display.
The options for this command form are described under “Options,” above.
Display statistics for a physical device.
The options for this subcommand are described under “Options,” above.
Display statistics for a link.
Show the network usage history from a stored extended accounting file. Use of this syntax requires that net accounting has been previously configured and enabled by using acctadm(1M). The default output is the summary of network usage of the existing links for the entire period when extended accounting was enabled.
The link argument is as described under “Options,” above.
Display all historical network usage for the specified period when extended accounting is enabled. This includes usage information about links that have already been deleted.
Specify the file from which extended accounting records of network usage history are read.
Display the dates for which there is logging information. The date is in the format mm/dd/yyyy.
Specify the output format of the network usage history information. gnuplot is the only supported format.
Specify start and stop times for data display. Time is in the format MM/DD/YYYY,hh:mm:ss. hh uses 24-hour clock notation.
Display per-port statistics for an aggregation.
The options for this subcommand are described under “Options,” above.
Example 1 Displaying Statistics
To display statistics for all the links, enter following command. Statistics are displayed as 3-digits followed by decimal and then 2 digits with the appropriate unit.
# dlstat LINK IPKTS RBYTES OPKTS OBYTES e1000g0 101.88K 32.86M 40.16K 4.37M nxge1 4.50M 6.78G 1.38M 90.90M vnic1 8 336 0 0 net0 73.96K 6.81M 0 0 zone1/net0 144.47K 13.32M 247 16.29K zone2/net0 132.89K 12.25M 236 15.82K
Example 2 Displaying RX-side Statistics
The following command displays receive-side statistics every one second.
# dlstat -r -i 1 LINK IPKTS RBYTES INTRS POLLS IDROPS e1000g0 101.91K 32.86M 87.56K 14.35K 0 nxge1 9.61M 14.47G 5.79M 3.82M 0 vnic1 8 336 0 0 0 e1000g0 0 0 0 0 0 nxge1 82.13K 123.69M 50.00K 32.13K 0 vnic1 0 0 0 0 0 . . . . . . . . . . . .
Example 3 Displaying Statistics per Hardware Ring
The following commands displays statistics on a per receive-side hardware ring basis.
# dlstat show-phys -r nxge1 LINK TYPE INDEX IPKTS RBYTES nxge1 rx 0 0 0 nxge1 rx 1 0 0 nxge1 rx 2 1.73M 2.61G nxge1 rx 3 0 0 nxge1 rx 4 8.44M 12.71G nxge1 rx 5 5.68M 8.56G nxge1 rx 6 4.90M 7.38G nxge1 rx 7 0 0
Example 4 Displaying Statistics per Lane
The following commands displays statistics on a per receive-side lane basis. First, an interface with dedicated hardware lanes:
# dlstat show-link -r nxge1 LINK TYPE ID INDEX IPKTS RBYTES INTRS POLLS IDROPS nxge1 rx local -- 0 0 0 0 0 nxge1 rx hw 1 0 0 0 0 0 nxge1 rx hw 2 1.73M 2.61G 1.33M 400.22K 0 nxge1 rx hw 3 0 0 0 0 0 nxge1 rx hw 4 8.44M 12.71G 4.35M 4.09M 0 nxge1 rx hw 5 5.68M 8.56G 3.72M 1.97M 0 nxge1 rx hw 6 4.90M 7.38G 3.11M 1.80M 0 nxge1 rx hw 7 0 0 0 0 0
Then, an interface without dedicated hardware lanes, that is, a software lane only:
# dlstat show-link -r ixgbe0 LINK TYPE ID INDEX IPKTS RBYTES INTRS POLLS IDROPS ixgbe0 rx local -- 0 0 0 0 0 ixgbe0 rx sw -- 794.28K 1.19G 794.28K 0 0
Example 5 Displaying Transmit-Side Statistics
The following command displays transmit-side statistics at five-second intervals.
# dlstat -t -i 5 LINK OPKTS OBYTES ODROPS e1000g0 40.24K 4.37M 0 nxge1 9.76M 644.14M 0 vnic1 0 0 0 e1000g0 0 0 0 nxge1 26.82K 1.77M 0 vnic1 0 0 0 . . . . . . . . . . . .
Example 6 Displaying Transmit-Side Ring Statistics
The following command displays transmit-side hardware ring statistics.
# dlstat show-phys -t nxge1 LINK TYPE INDEX OPKTS OBYTES nxge1 tx 0 44 3.96K nxge1 tx 1 0 0 nxge1 tx 2 1.48M 121.68M nxge1 tx 3 2.45M 201.11M nxge1 tx 4 1.47M 120.82M nxge1 tx 5 0 0 nxge1 tx 6 1.97M 161.57M nxge1 tx 7 4.59M 376.21M nxge1 tx 8 2.43M 199.24M nxge1 tx 9 0 0 nxge1 tx 10 3.23M 264.69M nxge1 tx 11 1.88M 153.96M
Example 7 Displaying Transmit-Side Lane Statistics
The following command displays transmit-side lane statistics.
# dlstat show-link -t nxge1 LINK TYPE ID INDEX OPKTS OBYTES ODROPS nxge1 tx hw 0 32 1.44K 0 nxge1 tx hw 1 0 0 0 nxge1 tx hw 2 1.48M 97.95M 0 nxge1 tx hw 3 2.45M 161.87M 0 nxge1 tx hw 4 1.47M 97.25M 0 nxge1 tx hw 5 3 276 0 nxge1 tx hw 6 1.97M 130.05M 0 nxge1 tx hw 7 4.59M 302.80M 0 nxge1 tx hw 8 2.42M 302.80M 0 nxge1 tx hw 9 0 0 0 nxge1 tx hw 10 3.23M 213.05M 0 nxge1 tx hw 11 1.88M 123.93M 0
Example 8 Selecting a Particular Set of Statistics
The following command shows how you can select a set of statistics of particular interest.
# dlstat show-link -r -o LINK,TYPE,ID,INDEX,INTRS,POLLS nxge1 LINK TYPE ID INDEX INTRS POLLS nxge1 rx local -- 0 0 nxge1 rx other -- 0 0 nxge1 rx hw 1 0 0 nxge1 rx hw 2 2.47M 753.90K nxge1 rx hw 3 0 0 nxge1 rx hw 4 8.24M 7.72M nxge1 rx hw 5 6.96M 3.68M nxge1 rx hw 6 5.82M 3.36M nxge1 rx hw 7 0 0
Example 9 Displaying Historical Network Usage
Network usage history statistics can be stored by using the extended accounting facility, acctadm(1M), with a command such as the following:
# acctadm -e basic -f /var/log/net.log net acctadm net Network accounting: active Network accounting file: /var/log/net.log Tracked Network resources: basic Untracked Network resources: src_ip,dst_ip,src_port,dst_port,protocol, dsfield
The saved historical data can then be retrieved in summary form with a command such as the following:
# dlstat show-link -h -f /var/log/net.log LINK DURATION IPACKETS RBYTES OPACKETS OBYTES BANDWIDTH e1000g0 80 1031 546908 0 0 2.44 Kbps
See attributes(5) for descriptions of the following attributes:
Screen output is Uncommitted. The invocation is Committed.