|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- frame buffer configuration utility
fbconfig [-dev device_file] [-help]
fbconfig -res \?
fbconfig [-dev device_file] [-file machine | system] [device_specific_options] [-res video-mode] [defaults] [-prconf] [-prdid[raw] [parsed]] [-propt]
fbconfig is the generic command line interface to query and/or to configure a frame buffer device. Depending on the command line options, fbconfig can invoke a GUI program, or it can invoke a device-specific configuration program. The choice of device configuration program depends both on the device (specified with -dev) and on the currently configured X server.
The options recognized by fbconfig are shown in the first three command forms in the SYNOPSIS section. The remaining forms illustrate options that may be passed to a device-specific configuration program that performs the actual operations. The interpretation of these options will depend upon the specific configuration program that is invoked. The options shown are supported by most device configuration programs.
If the -dev option is omitted, the default frame buffer (/dev/fb or /dev/fb0) is assumed.
The following options are supported by fbconfig:
Specify the frame buffer device by its full pathname or simple filename. Pathnames of installed devices can be displayed using the -list option. If the -dev option is omitted, the default device is /dev/fb.
Invoke the Graphical User Interface (GUI). The GUI is available if the SUNWdcm package is installed. All other options are ignored.
The GUI can configure devices (as an alternative to the fbconfig command line) and can update the Xservers file without directly editing the file. The GUI allows the user that is logged in on the graphics device or devices to configure which graphics displays the window system should use, their screen layout (where they appear on the user's desktop), and screen properties (X attributes).
In addition, the GUI allows advanced users to create a new video format (resolution) that some graphics devices can select from fbconfig command line or from the device-dependent portion of the GUI. The GUI's online help explains all options and features.
Displays the supported fbconfig command line options, along with a brief explanation of each. Also displays the -help text of the device-specific configuration program, if any. The frame buffer device can be specified using the -dev option, otherwise the default is used. Other fbconfig options are ignored. This is the default fbconfig option.
Displays the pathnames of the installed frame buffer devices, the device model of each, and the configuration program that would be invoked for each device with the currently configured X server. Other fbconfig options are ignored.
Device File Name Device Model Config Program ---------------- ------------ -------------- /dev/fbs/kfb0 XVR-2500 SUNWkfb_config /dev/fbs/kfb1 XVR-2500 SUNWkfb_config /dev/fbs/nfb0 [a|b] XVR-300 SUNWnfb_config /dev/fbs/pfb0 [a|b] XVR-100 SUNWpfb_config
The following options are commonly supported by the device-specific configuration programs:
Sets configuration options to their default values.
Specifies which xorg.conf configuration file to use.
Display the current configuration for the frame buffer and display device(s).
Display the E-EDID (Enhanced Extended Display Identification Data) information obtained from the display device(s), which must be online, connected to the frame buffer. The output will be raw hexadecimal and/or human-readable text. The default is parsed.
Display the current software configuration.
Display the video modes (resolutions) that can be used with the -res video-mode option.
Other supported options are determined by the device-specific configuration program:
The syntax and descriptions of additional device-specific options are displayed in the -help output of fbconfig or the device-specific program. They are also contained in the man page for the device-specific program.
See attributes(5) for descriptions of the following attributes:
Xserver(1), Xorg(1), Xsun(1), which are part of the OpenWindow, not the SunOS, man page collection.
Because of limitations in the m64 kernel driver and related software, fbconfig (with the -prconf option) is unable to distinguish between a current depth of 24 or 8+24. The -propt option returns the depth specified in the OWconfig file, which will be in effect following the next restart of the window system. The xwininfo utility, usually shipped in the package containing frame buffer software (such as SUNWxwplt), reports current depth of a specified window.