|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- set up a Kerberos Key Distribution Center (KDC)
/usr/sbin/kdcmgr [-a admprincipal] [-e enctype] [-h] [-p pwfile] [-r realm] subcommand
Use the kdcmgr utility to do the following:
Configure a master Key Distribution Center (KDC) server.
Configure a slave KDC. This assumes that a master KDC has already been configured. The default propagation method configured is incremental propagation. See kpropd(1M).
Specify a list of slave KDCs to configure service principals and create access control list for those slaves on the master KDC.
If you specify no options, kdcmgr prompts you for required information, including a password to generate the master key and a password for the administrative principal. When you specify sufficient options, you are still prompted for these passwords, unless you specified the -p pwfile option.
The kdcmgr utility must be run as superuser or by someone who has the Primary Administrator role. The command must be run on the server from which it is invoked.
Note that kdcmgr requires the user to enter sensitive information, such as the password used to generate the database's master key and the password for the administrative principal. Great care must be taken to ensure that the connection to the server is secured over the network, by using a protocol such as ssh(1).
You must also exercise great care when selecting the administrative and master key passwords. They should be derived from non-dictionary words and a long string of characters consisting of all of the following character classes:
special characters (for example, !@#$%^&*)
The following options are supported:
When creating a master KDC, specifies the administrative principal, admprincipal, that will be created.
When creating a slave KDC, admprincipal is used to authenticate as the administrative principal.
If you omit -a, the suggested default administrative principal name is the output of logname(1) appended by /admin.
Specifies the encryption type to be used when creating the key for the master key, which is used to encrypt all principal keys in the database. The set of valid encryption types used here are described in krb5.conf(4) under the permitted_enctypes option. Note that the encryption type specified here must be supported on all KDCs or else they will not be able to decrypt any of the principal keys. Solaris 9 and earlier releases support only the des-cbc-crc encryption type for the master key. Therefore, if any of the master or slave KDCs are of these older releases, then -e des-cbc-crc would need to be specified on all KDCs configured with kdcmgr.
The default encryption type is aes256-cts-hmac-sha1-96.
Displays usage information for kdcmgr.
Provides the location of the password file that contains the password used to create the administrative principal and/or master key.
Warning: This option should be used with great care. Make sure that this pwfile is accessible only by a privileged user and on a local file system. Once the KDC has been configured, you should remove pwfile.
Set the default realm for this server.
If the -r option is not specified, kdcmgr attempts to obtain the machine's local domain name by submitting the canonical form of the machine's host name to DNS and using the return value to derive the domain name. If successful, the domain name is converted to uppercase and proposed as the default realm name.
The following subcommands are supported:
Creates a KDC. If no option is specified, an attempt to create a master KDC is made.
masterkdc specifies the master KDC to authenticate and with which to perform administrative tasks. If the -m option is not specified, you are prompted for a master KDC host name.
Remove all Kerberos configuration and database files associated with the KDC server. A confirmation is required before these files are deleted.
Determines the role of the KDC, master or slave, and outputs this and the state of such associated processes as:
The subcommand also displays information on incremental propagation if the configuration has this feature enabled, as well as any issues with dependent files.
Example 1 Setting up a Master KDC
The following command configures a master KDC with the administrative principal user1/admin and with the realm name EXAMPLE.COM:
$ kdcmgr -a user1/admin -r EXAMPLE.COM create
Note that a password will be required to assign to the newly created user1/admin principal. The password for the master key will also need to be provided.
Example 2 Setting up a Slave KDC
The following command configures a slave KDC, authenticates with the administrative principal user1/admin, specifies kdc1 as the master, and uses the EXAMPLE.COM realm name:
$ kdcmgr -a user1/admin -r EXAMPLE.COM create -m kdc1 slave
Note that you must enter the correct password for user1/admin and that the master KDC must already have been created before entering this command. The correct password for the master key is also required.
Main Kerberos configuration file.
KDC configuration, used by both master and slave servers.
Default location of the local host's service keys.
Kerberos administrative access control list (ACL).
Service keys specific to kadmind(1M).
Kerberos principal database.
Kerberos policy database.
Used by slaves to indicate from which server to receive updates.
See attributes(5) for descriptions of the following attributes:
The command line interface (CLI) is Uncommitted. The CLI output is Not an Interface.