|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- create temporary snapshots of a file system
fssnap [-F FSType] [-V] -o special_options /mount/point
fssnap -d [-F FSType] [-V] /mount/point | dev
fssnap -i [-F FSType] [-V] [-o special_options] [/mount/point | dev]
The fssnap command creates a stable, read-only snapshot of a file system when given either an active mount point or a special device containing a mounted file system, as in the first form of the synopsis. A snapshot is a temporary image of a file system intended for backup operations.
While the snapshot file system is stable and consistent, an application updating files when the snapshot is created might leave these files in an internally inconsistent, truncated, or otherwise unusable state. In such a case, the snapshot will contain these partially written or corrupted files. It is a good idea to ensure active applications are suspended or checkpointed and their associated files are also consistent during snapshot creation.
File access times are not updated while the snapshot is being created.
A path to the virtual device that contains this snapshot is printed to standard output when a snapshot is created.
The following options are supported:
Deletes the snapshot associated with the given file system.
Specifies the file system type to be used. The FSType should either be specified here or be determined by matching the block special device with an entry in the /etc/vfstab table, or by consulting /etc/default/fs.
Displays the state of any given FSType snapshot. If a mount-point or device is not given, a list of all snapshots on the system is displayed. When a mount-point or device is specified, detailed information is provided for the specified file system snapshot by default. The format and meaning of this information is file-system dependent. See the FSType-specific fssnap man page for details.
See the FSType-specific man page for fssnap.
Echoes the complete command line, but does not execute the command.
The following operands are supported:
The directory where the file system resides.
See FSType-specific man pages for examples.
The following exit values are returned:
An error occurred.
Specifies file system type.
Specifies the default local file system type.
See attributes(5) for descriptions of the following attributes:
This command might not be supported for all FSTypes.