|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- install GRUB in a disk partition
/usr/sbin/installgrub [-fm] stage1 stage2 raw-device
The installgrub command is an x86–only program. GRUB stands for GRand Unified Bootloader.
installgrub installs GRUB stage 1 and stage 2 files on the boot area of a disk partition. If you specify the -m option, installgrub installs the stage 1 file on the master boot sector of the disk.
The installgrub command accepts the following options:
Suppresses interaction when overwriting the master boot sector.
Installs GRUB stage1 on the master boot sector interactively. You must use this option if Solaris is installed on an extended partition.
The installgrub command accepts the following operands:
The name of the GRUB stage 1 file.
The name of the GRUB stage 2 file.
The name of the device onto which GRUB code is to be installed. It must be a character device that is readable and writable. For disk devices, specify the slice where the GRUB menu file is located. (For Solaris it is the root slice.)
Example 1 Installing GRUB on a Hard Disk Slice
The following command installs GRUB on a system where the root slice is c0d0s0:
example# /usr/sbin/installgrub /boot/grub/stage1 \ /boot/grub/stage2 /dev/rdsk/c0d0s0
Directory where GRUB files reside.
See attributes(5) for descriptions of the following attributes:
Installing GRUB on the master boot sector (-m option) overrides any boot manager currently installed on the machine. The system will always boot the GRUB in the Solaris partition regardless of which fdisk partition is active.