|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- get printing configuration
lpget [-k key] [destination... | list]
The lpget utility reads printing configuration information from the configuration databases in $HOME/.printers and printers.org_dir printer. This information, called a configuration report, is displayed to the standard output.
lpget displays a configuration report for all keys for the specified destination or destinations by default. Use the -k option to display a configuration report for specific keys. Use the list operand to display a configuration report for all configured destinations.
The following option is supported:
Displays a configuration report for key.
The following operands are supported:
Displays a configuration report for destination. Destination can be either a printer of a class of printers. Specify destination using atomic or POSIX-style (server:destination) names. See standards(5) for information concerning POSIX.
Displays a configuration report for all configured destinations.
Example 1 Displaying a Configuration Report for the bsdaddr Key
The following example displays a configuration report for the bsdaddr key for printer catalpa.
example% lpget -k bsdaddr catalpa
Example 2 A Configuration Report for all Keys for all Configured Destinations
The following example displays a configuration report for all keys for all configured destinations.
example% lpget list
The following exit values are returned:
An error occurred.
User-configurable printer database.
See attributes(5) for descriptions of the following attributes:
If the LDAP database is used as the name service. If the ldapclient(1M) server is a replica LDAP server, LDAP printer database updates may not appear immediately, as the replica server may not have been updated by the master server and can be out of sync. For example, a printer that you deleted by using lpset(1M) may still appear in the printer list you display with lpget until the replica is updated from the master. Replica servers vary as to how often they are updated from the master. Refer to the Oracle Solaris Administration: Naming and Directory Services for more information on LDAP replication.