|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- parse the Data Recording Format tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_FORMAT(client_handle_t ch, tuple_t *tu, cistpl_format_t *pt);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cistpl_format_t structure which contains the parsed CISTPL_FORMAT tuple information upon return from this function.
This function parses the Data Recording Format tuple, CISTPL_FORMAT, into a form usable by PC Card drivers.
The CISTPL_FORMAT tuple indicates the data recording format for a device partition.
The structure members of cistpl_format_t are:
uint32_t type; uint32_t edc_length; uint32_t edc_type; uint32_t offset; uint32_t nbytes; uint32_t dev.disk.bksize; uint32_t dev.disk.nblocks; uint32_t dev.disk.edcloc; uint32_t dev.mem.flags; uint32_t dev.mem.reserved; caddr_t dev.mem.address; uint32_t dev.mem.edcloc;
The fields are defined as follows:
This field indicates the type of device:
This field indicates the error detection code length.
This field indicates the error detection code type.
This field indicates the offset of the first byte of data in this partition.
This field indicates the number of bytes of data in this partition
This field indicates the block size, for disk devices.
This field indicates the number of blocks, for disk devices.
This field indicates the location of the error detection code, for disk devices.
This field provides flags, for memory devices. Valid flags are:
address is valid
automatically map memory region
This field is reserved.
This field indicates the physical address, for memory devices.
This field indicates the location of the error detection code, for memory devices.
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA