|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- return driver binding name
#include <sys/ddi.h> #include <sys/sunddi.h> char *ddi_binding_name(dev_info_t *dip);
char *ddi_get_name(dev_info_t *dip);
Solaris DDI specific (Solaris DDI).
A pointer to the device's dev_info structure.
ddi_binding_name() and ddi_get_name() return the driver binding name. This is the name used to select a driver for the device. This name is typically derived from the device name property or the device compatible property. The name returned may be a driver alias or the driver name.
ddi_binding_name() and ddi_get_name() return the name used to bind a driver to a device.
ddi_binding_name() and ddi_get_name() can be called from user, kernel, or interrupt context.
The name returned by ddi_binding_name() and ddi_get_name() is read-only.