|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- reset a function on a PC card
#include <sys/pccard.h> int32_t csx_ResetFunction(client_handle_t ch, reset_function_t *rf);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a reset_function_t structure.
csx_ResetFunction() requests that the specified function on the PC card initiate a reset operation.
The structure members of reset_function_t are:
uint32_t Socket; /* socket number */ uint32_t Attributes; /* reset attributes */
The fields are defined as follows:
Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number.
Must be 0.
Card Services has noted the reset request.
This Card Services implementation does not permit configured cards to be reset.
Client handle is invalid.
No PC card in socket.
Specified socket or function number is invalid.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA
csx_ResetFunction() has not been implemented in this release and always returns CS_IN_USE.