|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- initialize and get the FM capabilities for a device instance
#include <sys/ddifm.h> void ddi_fm_init(dev_info_t *dip, int *fm_capability, ddi_iblock_cookie_t *ibcp);
void ddi_fm_fini(dev_info_t *dip);
int ddi_fm_capable(dev_info_t *dip, int *fm_capability);
Solaris DDI specific (Solaris DDI)
Pointer to the dev_info structure
Fault Management capability bit mask
Pointer to where the interrupt block cookie should be returned.
A device driver can declare its fault management capabilities to the I/O Fault Management framework by calling ddi_fm_init(). The ddi_fm_init() function allocates and initializes resources according to the bitwise-inclusive-OR of the fault management capabilities, described in the following and supported by the driver's immediate nexus parent.
The driver does not support any FMA features. This is the default value assigned to device drivers.
The driver generates FMA protocol error events (ereports) upon the detection of an error condition.
The driver checks for errors upon the completion of one or more access I/O transactions.
The driver checks for errors upon the completion of one or more DMA I/O transactions.
The driver is capable of error handler callback registration.
If the parent nexus is not capable of supporting any one of the requested capabilities, the associated bit will not be set and returned as such to the driver. Before returning from ddi_fm_init(), the I/O Fault Management framework creates a set of fault management capability properties: fm-ereport-capable, fm-errcb-capable, fm-accchk-capable, and fm-dmachk-capable. The current supported fault management capability levels are observable via prtconf(1M).
A driver can support the administrative selection of fault management capabilities by exporting and setting a fault management capability level property in its driver.conf(4) file to the values described above. The fm_capable properties must be set and read prior to calling ddi_fm_init() with the desired capability list.
This function cleans up resources allocated to support fault management for the dip structure.
This function returns the capability bit mask currently set for the dip structure.
See attributes(5) for descriptions of the following attributes: