|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- find descriptor in SCSI sense data
#include <sys/scsi/scsi.h> int scsi_validate_sense(uint8_t *sense_buffer, int sense_buf_len, int *flags);
Solaris DDI specific (Solaris DDI).
Pointer to a buffer containing SCSI sense data. The sense data is expected in wire format starting at the response code.
Length of sense buffer in bytes.
Returns additional properties of the sense data.
The scsi_validate_sense() function returns the format of the sense data contained in the provided sense buffer. If the response code field in the sense data is not recognized or if there is not enough sense data to include sense key, asc, and ascq then scsi_validate_sense() returns SENSE_UNUSABLE. If the buffer contains usable sense data in fixed format, the function returns SENSE_FIXED_FORMAT. If the buffer contains usable sense data in descriptor format, the function returns SENSE_DESCR_FORMAT.
The following flags may be set as appropriate depending on the sense data:
The sense data buffer provided for the request is too small to hold all the sense data.
The sense data contained in the buffer relates to an error that has occurred during the processing of a successfully completed command, such as a cached write that could not be committed to the media.
The response code from the sense data is unrecognized or not enough sense data present to provide the sense key, asc, and ascq.
The sense data in the buffer is in “fixed format”.
The sense data in the buffer is in “descriptor format”.
The scsi_validate_sense() function can be called from user or interrupt context.