|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- determine a network address for a given interface
#include <sys/neti.h> int net_getlifaddr(const net_data_t net, const phy_if_t ifp, const net_if_t lif, int const type, struct sockaddr* storage);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_lookup(9F).
indicates the logical interface from which to fetch the address.
indicates what type of address should be returned. See below for more details on this field.
pointer to an area of memory to store the address data.
The net_getlifaddr() function retrieves the address information for each logical interface. Each call to net_getlifaddr() requires that the caller pass a pointer to an array of address information types to retrieve, and an accompanying pointer to an array of pointers to struct sockaddr structures to which to copy the address information. See net_lifgetnext(9F) for an example on how to use this function.
Each member of the address type array should be one of the values listed here.
Return the network address associated with the logical interface (lif) that belongs to the network interface (ifp).
Return the address assigned to the remote host for point to point network interfaces for the given network/logical interface.
Return the broadcast address assigned to the given network/logical interface for network interfaces that support broadcast packets.
Return the netmask associated with the given network/logical interface for network interfaces that support broadcast packets.
The net_getlifaddr() function returns:
The network protocol does not support this function.
The net_getifaddr() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: