|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- parse the Data Organization tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_ORG(client_handle_t ch, tuple_t *tu, cistpl_org_t *pt);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cistpl_org_t structure which contains the parsed CISTPL_ORG tuple information upon return from this function.
This function parses the Data Organization tuple, CISTPL_ORG, into a form usable by PC Card drivers.
The CISTPL_ORG tuple provides a text description of the organization.
The structure members of cistpl_org_t are:
uint32_t type; char desc[CIS_MAX_TUPLE_DATA_LEN];
The fields are defined as follows:
This field indicates type of data organization.
This field provides the text description of this organization.
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA