|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- USB user-defined pipe data-field facility
#include <sys/usb/usba.h> int usb_pipe_set_private(usb_pipe_handle_t pipe_handle, usb_opaque_t data);
usb_opaque_t usb_pipe_get_private (usb_pipe_handle_t pipe_handle);
Solaris DDI specific (Solaris DDI)
Pipe handle into which user-defined data is placed.
Data to store in the pipe handle.
Pipe handle from which user-defined data is retrieved.
The usb_set_driver_private() function initializes the user-private data field of the pipe referred to by pipe_handle, using data. The user-private data field is used to store any data the client desires and is not used in any way by the USBA or OS framework. Client drivers often store their soft-state here for convenient retrieval by their callback handlers.
The usb_get_driver_private() function retrieves the user-private data stored via usb_set_driver_private(), from the pipe referred to by pipe_handle.
Private data has been successfully stored in pipe handle.
pipe_handle argument is NULL or invalid.
Pipe is closing or closed.
The pipe_handle argument refers to the default control pipe.
On success: usb_opaque_t pointer to data being retrieved.
On failure: NULL. Fails if pipe handle is NULL or invalid. Fails if pipe handle is to a pipe which is closing or closed.
May be called from user, kernel or interrupt context.
usb_pipe_handle_t pipe; /* Some driver defined datatype. */ xxx_data_t *data = kmem_zalloc(...); usb_pipe_set_private(pipe, data); ---- xxx_data_t *xxx_data_ptr = (xxx_data_t *)usb_pipe_get_private(pipe);
See attributes(5) for descriptions of the following attributes: