- search and list naming information from an LDAP directory using the configured profile
/usr/bin/ldaplist [-dlv] [database [key]...]
The ldaplist utility searches for and lists the naming information from the LDAP directory service defined in the LDAP configuration files generated by ldapclient(1M) during the client initialization phase. The Solaris LDAP client must be set up in order to use this utility.
The database is either a container name or a database name as defined in nsswitch.conf(4). A container is a non-leaf entry in the Directory Information Tree (DIT) that contains naming service information. The container name is the LDAP Relative Distinguished Name (RDN) of the container relative to the defaultSearchBase as defined in the configuration files. For example, for a container named ou=people, the database name is the database specified in nsswitch.conf. This database is mapped to a container, for example, passwd maps to ou=people. If an invalid database is specified, it is mapped to a generic container, for example, nisMapName=name).
The key is the attribute value to be searched in the database. You can specify more than one key to be searched in the same database. The key can be specified in either of two forms: attribute=value or value. In the first case, ldaplist passes the search key to the server. In the latter case, an attribute is assigned depending on how the database is specified. If the database is a container name, then the “cn” attribute type is used. If the database is a valid database name as defined in the nsswitch.conf, then a predefined attribute type is used (see table below). If the database is an invalid database name, then cn is used as the attribute type.
The ldaplist utility relies on the Schema defined in the RFC 2307bis, currently an IETF draft. The data stored on the LDAP server must be stored based on this Schema, unless the profile contains schema mapping definitions. For more information on schema mapping see ldapclient(1M). The following table lists the default mapping from the database names to the container, the LDAP object class, and the attribute type used if not defined in the key.
Database Object Class Attribute Type Container aliases mailGroup cn ou=Aliases automount nisObject cn automountMapName=auto_* bootparams bootableDevice cn ou=Ethers ethers ieee802Device cn ou=Ethers group posixgroup cn ou=Group hosts ipHost cn ou=Hosts ipnodes ipHost cn ou=Hosts netgroup ipNetgroup cn ou=Netgroup netmasks ipNetwork ipnetworknumber ou=Networks networks ipNetwork ipnetworknumber ou=Networks passwd posixAccount uid ou=People protocols ipProtocol cn ou=Protocols publickey nisKeyObject uidnumber ou=People cn ou=Hosts rpc oncRpc cn ou=Rpc services ipService cn ou=Services printers printerService printer-uri ou=printers auth_attr SolarisAuthAttr nameT ou=SolarisAuthAttr prof_attr SolarisProfAttr nameT ou=SolarisProfAttr exec_attr SolarisExecAttr nameT ou=SolarisProfAttr user_attr SolarisUserAttr uidT ou=people audit_user SolarisAuditUser uidT ou=people
The following databases are available only if the system is configured with Trusted Extensions:
tnrhtp ipTnetTemplate ipTnetTemplateName ou=ipTnet tnrhdb ipTnetHost ipTnetNumber ou=ipTnet
For the automount database, auto_*, in the container column, represents auto_home, auto_direct, …
For the publickey database, if the key starts with a digit, it is interpreted as an uid number. If the key starts with a non-digit, it is interpreted as a host name.
The ldaplist utility supports substring search by using the wildcard “*” in the key. For example, “my*” matches any strings that starts with “my”. In some shell environments, keys containing the wildcard may need to be quoted.
If the key is not specified, all the containers in the current search baseDN is listed.
The following options are supported:
Lists the attributes for the specified database, rather than the entries. By default, the entries are listed.
Lists the database mapping.
Lists all the attributes for each entry matching the search criteria. By default, ldaplist lists only the Distinguished Name of the entries found.
Sets verbose mode. The ldaplist utility also prints the filter used to search for the entry. The filter is prefixed with “+++”.
Example 1 Listing All Entries in the Hosts Database
The following example lists all entries in the hosts database:
example% ldaplist hosts
Example 2 Listing All Entries in a Non-Standard Database ou=new
The following example lists all entries in a non-standard database:
example% ldaplist ou=new
Example 3 Finding user1 in the passwd Database
The following example finds user1 in the passwd database:
example% ldaplist passwd user1
Example 4 Finding the Entry With Service Port of 4045 in the services Database
The following example finds the entry with the service port of 4045 in the services database:
example% ldaplist services ipServicePort=4045
Example 5 Finding All Users With Username Starting with new in the passwd Database
The following example finds all users with the username starting with new in the passwd database:
example% ldaplist passwd 'new*'
Example 6 Listing the Attributes for the hosts Database
The following example lists the attributes for the hosts database:
example% ldaplist -d hosts
The following exit values are returned:
Successfully matched some entries.
Successfully searched the table and no matches were found.
An error occurred. An error message is output.
Files that contain the LDAP configuration of the client. Do not manually modify these files. Their content is not guaranteed to be human readable. To update these files, use ldapclient(1M)
See attributes(5) for descriptions of the following attributes:
RFC 2307bis is an IETF informational document in draft stage that defines an approach for using LDAP as a naming service.