|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- setup system files for root (/) metadevice
/usr/sbin/metaroot [-n] [-k system-name] [-v vfstab-name] [-c mddb.cf-name] [-m md.conf-name] [-R root-path] device
The metaroot command edits the /etc/vfstab and /etc/system files so that the system may be booted with the root file system (/) on an appropriate metadevice. The only metadevices that support the root file system are a stripe with only a single slice or a mirror on a single-slice stripe.
If necessary, the metaroot command can reset a system that has been configured to boot the root file system (/) on a metadevice so that it uses a physical slice.
Root privileges are required for all of the following options except -h.
The following options are supported:
Use mddb.cf-name instead of the default /etc/lvm/mddb.cf file as a source of metadevice database locations.
Display a usage message.
Edit a user-supplied system-name instead of the default /etc/system system configuration information file.
Edit the configuration file specified by md.conf-name rather than the default, /kernel/drv/md.conf.
Print what would be done without actually doing it.
When metaroot modifies system files, it accesses them in their relative location under root-path.
The -R option cannot be used in combination with the -c, -k,-m, or -v options.
Note - The root file system of any non-global zones must not be referenced with the -R option. Doing so might damage the global zone's file system, might compromise the security of the global zone, and might damage the non-global zone's file system. See zones(5).
Edit vfstab-name instead of the default /etc/vfstab table of file system defaults.
The following operands are supported:
Specifies either the metadevice or the conventional disk device (slice) used for the root file system (/).
Example 1 Specifying Root File System on Metadevice
The following command edits /etc/system and /etc/vfstab to specify that the root file system is now on metadevice d0.
# metaroot d0
The following example shows the same command using a desriptive name for the metadevice.
# metaroot newrootfilesystem
Example 2 Specifying Root File System on SCSI Disk
The following command edits /etc/system and /etc/vfstab to specify that the root file system is now on the SCSI disk device /dev/dsk/c0t3d0s0.
# metaroot /dev/dsk/c0t3d0s0
System configuration information file. See system(4).
File system defaults.
Metadevice state database locations.
Configuration file for the metadevice driver, md.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
mdmonitord(1M), metaclear(1M), metadb(1M), metadetach(1M), metahs(1M), metainit(1M), metaoffline(1M), metaonline(1M), metaparam(1M), metarecover(1M), metarename(1M), metareplace(1M), metaset(1M), metassist(1M), metastat(1M), metasync(1M), metattach(1M), md.tab(4), md.cf(4), mddb.cf(4), md.tab(4), attributes(5), md(7D)