|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- delete a project from the system
projdel [-f filename] project
The projdel utility deletes a project from the system and makes the appropriate changes to the system file.
The following options are supported:
Specify the project file to modify. If no filename is specified, the system project file, /etc/project, is modified.
The following operands are supported:
The name of the project to be deleted.
The following exit values are returned:
The command syntax was invalid. A usage message for projdel is displayed.
An invalid argument was provided to an option.
The projid given with the -p option is already in use.
The project files contain an error. See project(4).
The project to be modified, group, user, or resource does not exist.
The project is already in use.
Cannot update the /etc/project file.
System project file
See attributes(5) for descriptions of the following attributes:
Invocation is evolving. Human readable output is unstable.
In case of an error, projdel prints an error message and exits with a non-zero status.
projdel deletes a project definition only on the local system. If a network name service such as NIS or LDAP is being used to supplement the local /etc/project file with additional entries, projdel cannot change information supplied by the network name service.