|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- password/group file checkers
pwck scans the password file and notes any inconsistencies. The checks include validation of the number of fields, login name, user ID, group ID, and whether the login directory and the program-to-use-as-shell exist. The default password file is /etc/passwd.
grpck verifies all entries in the group file. This verification includes a check of the number of fields, group name, group ID, whether any login names belong to more than NGROUPS_MAX groups, and that all login names appear in the password file. grpck also issues a warning if it finds an entry (a single line) in the group file longer than 2047 characters. Such an entry causes group maintenance commands, such as groupdel(1M) and groupmod(1M), to fail.
The default group file is /etc/group.
All messages regarding inconsistent entries are placed on the stderr stream.
See attributes(5) for descriptions of the following attributes:
Group entries in /etc/group with no login names are flagged.
The /etc/passwd or /etc/group file is an empty file.
The /etc/passwd or /etc/group file does not exist.
If no filename argument is given, grpck checks the local group file, /etc/group, and also makes sure that all login names encountered in the checked group file are known to the system getpwent(3C) routine. This means that the login names may be supplied by a network name service.