|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- fbconfig module for configuring Sun XVR-1000 Graphics Accelerator
fbconfig [-dev device-filename] [-active a | b | both | auto] [-res video-mode [now | try] [noconfirm]] [-file machine | system] [-doublewide enable | disable | reverse] [-doublehigh enable | disable | reverse] [-multisample enable | disable | auto [static | dynamic]] [-samples samples-per-pixel] [-g gamma-correction-value] [-master a | b | input] [-clearpixel0 | 255]
fbconfig [-dev device-filename] -stream a | b [-port hd15 | dvid | svideo | auto] [-res video-mode [now | try] [noconfirm]] [-file machine | system] [-offset xoff-value [yoff-value]] [-slave [enable | disable] [internal | external]]
fbconfig [-dev device-filename] -defaults
fbconfig [-dev device-filename] [-propt | -prconf | -res \?]
fbconfig [-help | -list]
SUNWgfb_config is the Sun XVR-1000 Graphics Accelerator device dependent layer for fbconfig(1M). It configures the Sun XVR-1000 Graphics Accelerator and some of the X11 window system defaults. The device can drive two monitors, each with a unique video stream (called stream a and stream b).
The first form of SUNWgfb_config shown in the synopsis above sets card options, which are options common to both stream a and stream b, and apply to the entire card.
The second form is used to set stream options, which are options specific to either stream a or stream b. The second form usage requires the -stream option to define which stream is affected.
Both the first form and the second form store the specified options in the OWconfig file. These options will be used to initialize the device the next time the window system is run on that device. Updating options in the OWconfig file provides persistence of these options across window system sessions and system reboots. For -res with now or try, -slave, -master, -port, and -g , the device will be immediately programmed.
The third form, which invokes the -defaults option, sets all card options and all stream options to their default values and saves these defaults in the OWconfig file.
The fourth form, which invokes the -prconf, -propt, and -res \? options, queries the device for status that is card-specific.
The fifth form, which invokes the -help, and -list options, provides instruction on using SUNWgfb_config and a list of available devices. Additionally for the fifth form, all other options are ignored.
You can specify options for only one device at a time. Specifying options for multiple devices requires multiple invocations of SUNWgfb_config.
Only Sun XVR-1000 Graphics Accelerator-specific options can be specified through SUNWgfb_config. The normal window system options for specifying default depth, default visual class, and so forth are still specified as device modifiers on the command line when the X server is started.
You can also specify the OWconfig file that is to be updated. By default, the machine-specific file in the /etc/openwin directory tree is updated. You can use the -file option to specify an alternate file. For example, the system-global OWconfig file in the /usr/openwin directory tree can be updated instead.
Specifies the device's special file. The default is /dev/fb.
Specifies which OWconfig file to update. If machine is specified, the machine-specific OWconfig file in the /etc/openwin directory tree is updated. If system is specified, the global OWconfig file in the /usr/openwin directory tree is updated. If the specified file does not exist, it is created. This option has no effect unless other options are specified. The default is machine.
Specifies the video mode used to drive the monitor connected to the specified device. If -res is invoked with now or try, you must specify a -stream option or a device, such as /dev/fbs/gfb0a. If -active is set to both or auto, then both stream video-mode values will be modified.
The video-mode argument specifies resolution and timing information for the display (for example, SUNW_STD_1280x1024x76). The naming convention for the video-mode specifier is:
The elements of the specifier are described as follows:
This can be one of:
SUNW, Sun derived resolution
VESA, Video Electronics Standards Association-derived resolution
other, other source
This can be one of:
STD, normal resolution, usable by most display devices
DIG, resolution tuned only for LCD flat panels
screen width in pixels
screen height in pixels
vertical frequency of the screen refresh
Note that some video-modes supported by the device, might not be supported by the monitor. The list of video-modes supported by the device and the monitor can be obtained by running SUNWgfb_config with the -res \? option (the fourth form shown in the command synopsis above).
The -res option also accepts additional, optional arguments, listed below, immediately following the video mode specification. Either now or try (try subsumes now) and noconfirm can be present.
If present, not only is the video mode updated in the OWconfig file, but the device is immediately programmed to display this video mode. This is useful for changing the video mode before starting the window system.
Note - It is recommended that you not use this suboption with SUNWgfb_config while the configured device is being used (for example, while running the window system). Unpredictable results can occur. To run SUNWgfb_config with the now suboption, first bring the window system down. If the now suboption is used within a window system session, the video mode is changed immediately, but the width and height of the affected screen do not change until the window system is exited and reentered. In addition, the system might not recognize changes in stereo mode.
Using the -res option, the user can put the system into an unusable state, with no video output. To reduce the chance of this, the default behavior of SUNWgfb_config is to display a warning message and to ask the user whether to continue. The noconfirm bypasses this confirmation. This option is useful when SUNWgfb_config is being run from a shell script.
If present, the specified video mode will be programmed on a trial basis. The user is asked to confirm the video mode by typing y within 10 seconds. Alternatively, the user can terminate the trial before 10 seconds elapse by typing any character other than y or carriage return. Such input is considered a no and the previous video mode is restored. With a negative response, SUNWgfb_config does not change the video mode in the OWconfig file; other options specified still take effect. If a carriage return is typed, the user is asked (y or n) whether to keep the new video mode.
This sub-option should not be used with SUNWgfb_config while the configured device is being used (for example, while running the window system) as unpredictable results may occur. To run SUNWgfb_config with the try sub-option, the window system should be brought down first.
Resets all option values to their default values. Writes these values to the OWconfig file.
Displays the current values of all options in the OWconfig file specified by the -file option for the device specified by the -dev option. Displays the values of options as they will be in the OWconfig file after the call to SUNWgfb_config completes. The following is an example display:
--- OpenWindows Configuration for /dev/fbs/gfb0 --- OWconfig: machine Active Streams: both Samples Per Pixel: 2 Multisample Allocation Model: static Multisample Mode: auto Doublewide: disable Gamma Correction Value: 2.22 --- OpenWindows Configuration for Stream a --- Video Mode: SUNW_STD_1280x1024x76 --- OpenWindows Configuration for Stream b --- Video Mode: VESA_STD_640x480x60
Displays the XVR-1000 hardware configuration. The following is an example display:
--- Hardware Configuration for /dev/fb (SUNWgfb0) --- Type: Sun Graphics Accelerator Part: 501-5865 Memory: MAJC: 32MB Texture: 256MB total 3DRAM64: 5.0M pixels Versions: FCode 1.14 MCode 0.19 MAJC 2.1 FBC3 3.0 XChip 2.0 Video Streams: Stream a Current resolution Setting: SUNW_STD_1280x1024x76 Monitor/EDID data (13W3) Monitor Manufacturer: SUN Monitor Name: GDM-5410 EDID: Version 1, Revision 2 Stream b Current resolution Setting: VESA_STD_640x480x60 Port: svideo
Displays a list of the SUNWgfb_config command line options, along with a brief explanation of each.
Displays list of defined video-mode names.
Specifies which streams are enabled. both select both streams. The default is auto, which means whichever stream is chosen by the console.
The suboptions for -multisample are described as follows:
No multisample is possible.
Multisample is possible but is selected on a per-application basis.
All Sun OpenGL applications are rendered using multisampling.
Multisample allocation occurs at X startup/config load time. The config samples-per-pixel or max parameter specifies the depth that is pre-allocated.
OpenGL tasks allocate buffers themselves.
Specifies the number of samples/pixel to pre-allocate in static mode. Provides a hint to OpenGL in dynamic mode. The allowable choices for samples-per-pixel are 2, 3, 4, 5, 6, 8, 10, 16, and max. The default is max, which means to use the maximum number of samples that can be supported with the amount of memory available.
This option makes it easy for you to combine both streams into one side-by-side virtual display. If you specify enable, stream a is to the left of stream b. If reverse is specified, stream b is to the left of stream b. Both will be the same resolution defined with the -res option. If you specify disable, only one stream will be enabled. -doublewide precludes -doublehigh.
This option makes it easy for you to combine both streams into one virtual display, with one monitor on a shelf above the other. If you specify enable, stream a is above stream b. If reverse is specified, stream b is above stream a. Both will be the same resolution defined with the -res option. If you specify disable, only one stream will be enabled. -doublehigh precludes -doublewide.
This option changes the gamma correction value. By default the gamma correction value is 2.22. Any value less than zero is illegal. This option can be used while the window system is running. Changing the gamma correction value will affect all the windows being displayed using gamma-corrected visuals. The gamma correction value is also saved in the OWconfig file for the next time the window system starts.
This option controls the setting frame pins on the stereo/sync connector on the device. It also controls which stream drives stereo glasses, which attach to the same connector.
If a (the default) or b is selected, the card is setup to be a sync master, and the frame sync signal from the corresponding stream will be sent out this connector.
If you select input, the card is setup to take its frame sync from another card through this connector. This sync can then be used to sync either or both streams by setting the stream-specific -slave option(s) to external.
If stereo glasses are used, the a or b options select which stream is used for the sync signal to the glasses.
Selects the overlay transparent color. This is the pixel value (color index) used by the transparent overlay visual to display the underlay (RGB) pixel contents. The default is 255 (all bits 1), but some applications require 0. All other color indices display a colormap color.
Specifies for which stream options will be set. It is a required option for each of the other options in this section. It is optional for -res. Only one -stream option can be specified.
Directs stream b to the appropriate output connector: hd-15, dvid, or svideo. If auto, then the output connector for stream b is selected by the console. Stream a is always output through the 13W3 connector.
Offsets the display of the stream (specified by -stream) relative to the adjoining edge of the other stream when doublewide or doublehigh is enabled. This can be used to cause an overlap.
Number of pixels offset in horizontal direction for the right-hand stream when doublewide is enabled. Positive direction is to the right (create a gap); negative is to the left (overlap the streams). Default is 0, which means the two edges touch.
Number of pixels offset in vertical direction for the bottom stream when doublehigh is enabled. Positive direction is down (create a gap); negative is up (overlap the streams). Default is 0, which means the two edges touch.
This option allows you to specify the sync source for the specified stream. internal indicates that the sync source is the other stream of this device. external indicates the sync is taken from a source outside the device. If you use external, you also need to use the card option -master input.
For a given invocation of SUNWgfb_config, if an option does not appear on the command line, the corresponding OWconfig option is not updated. It retains its previous value.
When the window system is run, if an option has never been specified through SUNWgfb_config, a default value is used. The option defaults are as follows:
The default for the -res option of none means that, when the window system is run, the screen resolution will be the video mode that is currently programmed in the device. This provides compatibility for users who are used to specifying the device resolution through the PROM.
Example 1 Switching Resolution of a Monitor
The following example switches to the resolution of 1280 by 1024 at 76 Hz:
example% fbconfig -stream a -res -SUNW_STD_1280x1024x76
device special file
See attributes(5) for descriptions of the following attributes:
See the dtlogin(1) man page in the CDE man page collection. Also useful is the Xsun(1) man page in the OpenWindows man page collection.