|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- Sun Solstice Enterprise Master Agent
/usr/lib/snmp/snmpdx [-hy] [-a filename] [-c config-dir] [-d debug-level] [-i filename] [-m GROUP -m SPLIT] [-o filename] [-p port] [-r filename]
The Master Agent, snmpdx, is the main component of Solstice Enterprise Agent (SEA) technology. It runs as a daemon process and listens to User Datagram Protocol (UDP) port 161 for SNMP requests. The Master Agent also opens another port to receive SNMP trap notifications from various subagents. These traps are forwarded to various managers, as determined by the configuration file.
Upon invocation, snmpdx reads its various configuration files and takes appropriate actions by activating subagents, determining the subtree Object Identifier (OID) for various subagents, populating its own Management Information Bases (MIBs), and so forth. The Master Agent invokes subagents, registers subagents, sends requests to subagents, receives responses from subagents, and traps notifications from subagents.
The Master Agent is invoked by the service management facility smf(5) at boot time if svc:/application/management/snmpdx is enabled (see NOTES) and contents of the resource configuration file /etc/snmp/conf/snmpdx.rsrc are non-trivial.
Note - The SMA (Systems Management Agent) is the default SNMP agent in the Solaris operating system. snmpdx is Obsolete and may not be supported in a future release of Solaris.
The following options are supported:
Specify the full path of the access control file used by the Master Agent. The default access control file is /etc/snmp/conf/snmpdx.acl.
Specify the full path of the directory containing the Master Agent configuration files. The default directory is /etc/snmp/conf.
Debug. Levels from 0 to 4 are supported, giving various levels of debug information. The default is 0 which means no debug information is given.
Help. Print the command line usage.
Specify the full path of the enterprise-name OID map. This file contains the PID used by the Master Agent for recovery after a crash. It contains tuples of the UNIX process ID, port number, resource name, and agent name. The default file is /var/snmp/snmpdx.st.
Specify the mode to use for forwarding of SNMP requests.
Multiple variables can be included in each request from the Master Agent to the subagents. This results in, at mose, one send-request per agent.
Each variable in the incoming request results in one send-request to each subagent.
The default is GROUP.
Specify the full path of the file containing the tuple (enterprise-name, OID). For example, (Sun Microsystems, 22.214.171.124.1.4.32). The Master Agent uses this file as a base for look-up in the trap-filtering and forwarding process. The default file is /etc/snmp/conf/enterprises.oid.
Specify the port number. The default port number is 161.
Specify the full path of the resource file to be used by the Master Agent. This file stores information about the subagents that the Master Agent invokes and manages. The default resource file is /etc/snmp/conf/snmpdx.rsrc.
Set a recovery indicator to invoke the recovery module. The recovery process discovers which subagents in the previous session are still active; those subagents not active are re-spawned by the Master Agent.
Enterprise-name OID map
Access control file
Resource configuration file
Master Agent status file
Master Agent MIB file
The following error values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
The snmpdx service is managed by the service management facility, smf(5), under the service identifier: