|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- network auto-magic daemon
nwamd is a system daemon to manage network interfaces.
This daemon is started automatically and should not be invoked directly. It does not constitute a programming interface.
Whether this daemon is enabled or not depends on your installation medium. To check from within the GNOME desktop environment, double click on the “Network Manager” icon to open the “Connection Properties” window. If “Configure network automatically” is checked, then auto-magic mode is enabled. To check from the command line, enter the following:
% svcs svc:/network/physical
Two instances will be listed, one online and the other disabled. If the “nwam” instance is online, then this daemon is running.
To switch between manual and auto-magic mode, you can use the Network Monitor applet available within the GNOME desktop environment. You can also switch manually from the command line by entering:
% svcadm disable svc:/network/physical:default % svcadm enable svc:/network/physical:nwam
To go from auto-magic mode to manual mode:
% svcadm disable svc:/network/physical:nwam % svcadm enable svc:/network/physical:default
When switching modes like this, keep in mind that all network interfaces will be brought down then back up. Therefore, if a different IP address is configured in this process, existing applications and sessions might be disrupted.
The default configuration policy is to have one link active at a time. If a wired link is available (that is, physically connected), it will be preferred over wireless links. This default policy can be changed by creating alternate Network Configuration Profiles (NCPs); the nwam-manager GUI tool or the nwamcfg(1M) command can be used to create and modify NCPs.
If you used an earlier version of nwamd, which created an /etc/nwam/llp configuration file, configuration present in that file will automatically be incorporated into the “User” NCP upon upgrade to the current version of nwamd.
The automatic behavior provided by the NWAM service requires that management of the network configuration be handed over to nwamd. Thus, any manual changes to the network configuration might be lost if conditions change such that a new profile is activated, or if nwamd is restarted. If persistent changes are desired, the recommended approach is to create an External Network Modifier (ENM), which can be activated and deactivated as needed by the NWAM service.
The following list takes the form:
Enables debug logging using daemon.debug.
Indicates whether legacy configuration has been imported and updated to the current version. The property does not exist until a pre-version-1 configuration has been updated, at which time it is created with value set to 1.
Indicates whether open WLANs should be connected automatically, in the absence of a better (more preferred) choice.
The number of seconds to wait for an NCU (or link/interface NCU pair, as appropriate) to come up before trying the next available NCU. The bringup activity will not be cancelled, and may eventually succeed, at which time the more preferred NCU will be activated and the alternate might be disabled, depending on the specified configuration conditions.
The number of seconds between periodic condition checks for conditionally activated objects. Minimum value is 30 seconds.
The number of seconds between periodic wireless scans.
A signal strength threshold; if the currently connected AP drops below this signal level, and equivalent APs (of the same ESSID) are available at higher signal strength, the existing connection will be dropped in favor of a connection to an AP with stronger signal.
If true, both ESSID and BSSID must be matched in order to connect to a previously connected WLAN. If false, only an ESSID match is required.
The currently active NCP. This property should not be set by the user; it is used internally by the NWAM service for persistence across restarts. The appropriate user interface to change the currently active NCP is by means of the nwam-manager GUI or the nwamadm command's enable subcommand.
The NWAM service manages network configuration by storing desired property values in profiles. It then determines which profile should be active at a given time, depending on current network conditions, and activates that profile. In addition to the Network Configuration Profiles (NCPs) discussed in the previous section, nwamd also manages Location and ENM profiles.
An NCP specifies the configuration of the local network components, including physical links, IP tunnel links, and IP interfaces. An IP interface must be associated with an underlying link of either type. These components are collectively referred to as Network Configuration Units, or NCUs.
There can be any number of NCPs configured on a system. The Automatic NCP is created and managed by nwamd, and cannot be modified by the user. This NCP consists of one link NCU and one interface NCU for each physical link present in the system. As links are added or removed from the system, their corresponding NCUs will be added or removed from the Automatic NCP. The policy implemented in this NCP is to prefer wired links over wireless, and to plumb IP on all connected wired links, or one wireless link if no wired links are connected.
The system will also create a User NCP upon upgrade from an earlier version of the NWAM service, based on the configuration found in the old /etc/nwam/llp file. In most cases, the Automatic NCP will be active initially, even if a User NCP is created. However, if explicit changes, such as a static IP address, are detected in the old configuration, the User NCP will be active initially.
Finally, the user can create any number of additional NCPs. These NCPs are managed entirely by the user; NCUs must be added or removed explicitly, and it is possible to add NCUs that do not map to any link currently installed in the system, or to remove NCUs that do map to a link present in the system. The user can determine the policy for these NCPs.
After making its initial NCP selection, the system will not change the active NCP. The user may do this at any time using the GUI or the nwamadm(1M) command.
A Location specifies system-wide network configuration, including areas such as name services, domain, IP Filter, and IPsec configuration.
External Network Modifiers are, as the name suggests, applications external to the NWAM service that can modify and/or create network configuration. nwamd will activate/deactivate an ENM depending on conditions that are specified as part of the ENM profile. Alternatively, the user might choose to manually activate/deactivate ENMs as needed.
See attributes(5) for descriptions of the following attributes:
See also nwam-manager(1M), available in the JDS/GNOME man page collection.
The networking service is managed by the service management facility, smf(5), under the service identifier: