|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- report and analyze events that affect power management
powertop [-c processor_id] [-d count] [-t interval] [-v] [-h]
PowerTOP is an observability tool that shows how effectively the system is taking advantage of the CPU's power management features. By running the tool on an otherwise idle system, the user can see for how long the CPU is running at dif- ferent power states. Ideally, an unutilized (idle) system spends 100% of its time running at the lowest power state, but because of background user and kernel activity (random software periodically waking to poll status), idle systems can consume more power than they should.
The tool analyzes system activity periodically and displays a summary of how long the processor is executing at each supported power state. It also displays the top activities responsible for causing the CPU to wake up and use more energy. This report allows the user to identify and diagnose problematic areas of the system and optimize its power efficiency.
PowerTOP averages the amount of activity that is preventing the CPU from entering a lower power state and presents it on the “Wakeups-from-idle per second” field. This value represents the total number of wake-ups divided by the current interval. Notice that not all events are displayed on the screen at all times.
During execution, a user can force a refresh of the analysis by pressing the R key. The interval time is restored to the default or to a specified value. To quit the application, the user must press the Q key.
If you are running as root (superuser) or in the Primary Administrator role, the tool makes suggestions as how the system can be improved from a power management perspective.
PowerTOP allows you to freeze each of its three subwindows, enabling you to better analyze each subwindow's contents. When you have three different DTrace scripts running at the same time, freezing subwindows lowers CPU consumption . This feature is activated by pressing the i, f, or e key while the tool running. Pressing one of these keys freezes the idle, frequency, or event report, respectively. Pressing it once more, unfreezes it. This feature is most useful when invoked while the application being analyzed is running.
PowerTOP runs on xVM(5) domains. However, the report for idle state transitions might or might not be accurate as the physical CPU can be shared by different virtual CPUs. Both wakeup count and event report displays information regarding the current virtualized environment.
The following options are supported:
Specifies which CPU the tool should observe.
Dumps the results of count analysis of system activity to the screen.
Displays the command's usage.
Specifies the interval, in seconds, at which the tool analyzes the system. The possible values are in the range of 1 through 30; the default is 5 seconds.
Switches to verbose mode, including noting firings of the kernel cyclic subsystem in the event report.
Example 1 Setting the Interval
The following command sets the interval to two seconds.
% powertop -t 2
Example 2 Analyzing and Dumping System Activity
The following command analyzes and dumps system activity to the standard output four times.
% powertop -d 4
Example 3 Reporting Cyclic Subsystem Activity
The following command reports cyclic subsystem activity.
% powertop -v
Example 4 Analyzing Activity on a Specific Processor
The following command runs PowerTOP and only displays data for CPU 3:
% powertop -c 3
An error occurred.
See attributes(5) for descriptions of the following attributes:
Among non-SunOS man pages, xscreensaver(1) and dtpower(1M).
You must have DTrace privileges to run PowerTOP and root (superuser) privileges or assume the Primary Administrator role for the tool to suggest improvements to the system.