|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- SNMP notification daemon for software events
snmp-notify is a daemon that subscribes to software events and FMA diagnosis and repair events and generates SNMP trap notifications based on a set of notification preferences that are stored in the SMF service configuration repository.
SNMP notification preferences are set using svccfg(1M).
snmp-notify is managed by the service management facility, smf(5), under the service FMRI:
The following service properties can be set:
This is an astring property that defaults to /. When set, the specified root directory will be used for all pathnames evaluated by snmp-notify.
Example 1 Configuring Notification Preferences
The following command configures notification preferences for SMF service state transition events.
# svccfg setnotify -g from-online,to-maintenance snmp:active
Example 2 Enabling SNMP Notifications
The following command enables notifications for Fault Management diagnosis events.
# svccfg setnotify problem-diagnosed snmp:active
Example 3 Listing Notification Settings
The following command lists all notification settings for Fault Management diagnosis events.
# svccfg listnotify fma-diagnosis
Refer to svccfg(1M) for more information on configuring SNMP notification preferences.
See attributes(5) for descriptions of the following attributes: