|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- list available resources from remote or local systems
dfshares [-F FSType] [-h] [-o specific_options] [server]...
dfshares provides information about resources available to the host through a distributed file system of type FSType. specific_options as well as the semantics of server are specific to particular distributed file systems.
If dfshares is entered without arguments, all resources currently shared on the local system are displayed, regardless of file system type.
The output of dfshares consists of an optional header line (suppressed with the -h flag) followed by a list of lines containing whitespace-separated fields. For each resource, the fields are:
resource server access transport
Specifies the resource name that must be given to the mount(1M) command.
Specifies the name of the system that is making the resource available.
Specifies the access permissions granted to the client systems, either ro (for read-only) or rw (for read/write). If dfshares cannot determine access permissions, a hyphen (-) is displayed.
Specifies the transport provider over which the resource is shared.
A field may be null. Each null field is indicated by a hyphen (-) unless the remainder of the fields on the line are also null; in which case, the hyphen may be omitted.
Specify filesystem type. Defaults to the first entry in /etc/dfs/fstypes.
Suppress header line in output.
Specify options specific to the filesystem provided by the -F option.
See attributes(5) for descriptions of the following attributes: