|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- edit user quotas for ufs file system
edquota [-p proto_user] username...
edquota is a quota editor. One or more users may be specified on the command line. For each user a temporary file is created with an ASCII representation of the current disk quotas for that user for each mounted ufs file system that has a quotas file, and an editor is then invoked on the file. The quotas may then be modified, new quotas added, etc. Upon leaving the editor, edquota reads the temporary file and modifies the binary quota files to reflect the changes made.
The editor invoked is vi(1) unless the EDITOR environment variable specifies otherwise.
Only the super-user may edit quotas. In order for quotas to be established on a file system, the root directory of the file system must contain a file, owned by root, called quotas. (See quotaon(1M).)
proto_user and username can be numeric, corresponding to the UID of a user. Unassigned UIDs may be specified; unassigned names may not. In this way, default quotas can be established for users who are later assigned a UID.
If no options are specified, the temporary file created will have one or more lines of the format, where a block is considered to be a 1024 byte (1K) block:
fs mount_point blocks (soft =number, \ hard =number ) inodes (soft =number, \ hard =number)
The number fields may be modified to reflect desired values.
The following options are supported:
Duplicate the quotas of the proto_user specified for each username specified. This is the normal mechanism used to initialize quotas for groups of users.
Edit the soft time limits for each file system. If the time limits are zero, the default time limits in /usr/include/sys/fs/ufs_quota.h are used. The temporary file created will have one or more lines of the form
fs mount_point blocks time limit = number tmunit, files time limit = number tmunit
tmunit may be one of ``month'', ``week'', ``day'', ``hour'', ``min'' or ``sec''; characters appended to these keywords are ignored, so you may write ``months'' or ``minutes'' if you prefer. The number and tmunit fields may be modified to set desired values. Time limits are printed in the greatest possible time unit such that the value is greater than or equal to one. If ``default'' is printed after the tmunit, this indicates that the value shown is zero (the default).
See largefile(5) for the description of the behavior of edquota when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
quota file at the file system root
table of mounted file systems
See attributes(5) for descriptions of the following attributes:
All UIDs can be assigned quotas.