|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- hotplug daemon
The hotplug daemon, hotplugd, provides user-level services for the management of hotplug connections. It is a system daemon started by the Service Management Facility (see smf(5)). Its fault management resource identifier (FMRI) is:
Note that hotplugd is a Consolidation Private interface. See attributes(5).
The hotplug(1M) command and any other client program that uses the private libhotplug library to query information about hotplug connections or initiate hotplug commands depends upon this daemon. The hotplug daemon is a door server which services requests from all libhotplug clients. The door interface is private.
Client applications use the private libhotplug interface to administer hotplug connections. libhotplug uses the door interface to administer hotplug connections through the hotplug daemon service. The hotplug daemon acts as a central location to serialize all hotplug operations and coordinate activities with all other parts of the system.
The following option is supported:
Run the daemon in standalone debug mode. Messages will be displayed on the controlling terminal instead of to syslog. And increased verbosity will be enabled to display more details about the internal operations of the daemon.
Example 1 Enabling the Hotplug Service
The following command enables the hotplug service:
# svcadm enable svc:/system/hotplug:default
Example 2 Disabling the Hotplug Service
The following command disables the hotplug service:
# svcadm disable svc:/system/hotplug:default
The hotplug daemon uses syslog(3C) to report status and error messages. All of the messages are logged with the LOG_DAEMON facility. Error messages are logged with the LOG_ERR and LOG_NOTICE priorities, and informational messages are logged with the LOG_INFO priority. The default entries in the /etc/syslog.conf file log all of the hotplug daemon error messages to the /var/adm/messages log.
Hotplug daemon door
Hotplug daemon lock file
Hotplug daemon binary
See attributes(5) for descriptions of the following attributes:
The hotplugd service is managed by the service management facility, smf(5), under the fault management resource identifier (FMRI):
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). The service's status can be queried using the svcs(1) command. To administer the service, the authorization solaris.smf.manage.hotplug must be granted. Alternatively, the rights profile “Hotplug Management” can be granted.
The hotplug service must be enabled for the hotplug(1M) command and any other libhotplug client applications to function properly.