|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- FMLI-based interface to Live Upgrade functions
Sun no longer recommends use of the lu command. The lu command displays a character user interface (CUI). The underlying command sequence for the CUI--typically lucreate, luupgrade, and luactivate--is straightforward to use. The SEE ALSO section below highlights the full Solaris Live Upgrade command set.
The lu program is part of a suite of commands that make up the Live Upgrade feature of the Solaris operating environment. See live_upgrade(5) for a description of the Live Upgrade feature.
The lu program is a Forms and Menu Language Interpreter-based user interface. lu enables you to create and upgrade boot environments (BEs) and perform other administrative tasks on BEs. The lu program performs a subset of the functions provided by the Live Upgrade command-line utilities.
Users of lu should be aware of the following:
lu is a deprecated interface. It will be replaced in the future and should not be depended on for critical functionality.
All new Live Upgrade features are being implemented in the Live Upgrade command–line utilities. No new features are being made available in lu.
The lu command is not internationalized. It will not be internationalized in a future release.
lu should be used for learning or experimenting only. For any production use or to use the full capabilities of Live Upgrade, use the Live Upgrade command-line utilities.
Invocation of the lu command requires root privileges.
The lu command accepts no arguments. After invoking lu, you receive a display with the following options:
Activate a boot environment. This option designates that the system boot from the specified BE upon next reboot. This option is equivalent to the command-line luactivate(1M) utility.
Cancel a copy job. Live Upgrade allows you to schedule the copy, upgrade, and flash functions (all described below) at a later time. The cancel function enables you to cancel a scheduled job. This function is equivalent to the command-line lucancel(1M) utility.
Compare the contents of BEs. Enables you to obtain a detailed comparison of two BEs. Equivalent to the command-line lucompare(1M) utility.
Start/schedule a copy. Copies the contents of one BE to another. Equivalent of the command-line lumake(1M) utility. At any time, you can have only one Live Upgrade operation scheduled.
Create a boot environment. Implements a subset of the functions performed by the command-line lucreate(1M) utility.
Display the name of the current boot environment. Equivalent of the command-line lucurr(1M) utility.
Delete a boot environment. Equivalent of the command-line ludelete(1M) utility.
List the file systems of a boot environment. Equivalent of the command-line lufslist(1M) utility.
Change the name of a boot environment. Equivalent of the command-line lurename(1M) utility.
List the status of all boot environments. Equivalent of the command-line lustatus(1M) utility.
Upgrade a boot environment or upgrade the OS on an inactive BE. This option enables you to upgrade to a new operating system or install new packages or patches on a specified BE. Implements a subset of the functions performed by the command-line luupgrade(1M) utility. Note that if you are performing an upgrade that requires more than one CD, you must use the -i option of luupgrade.
Flash a boot environment. This option enables you to install an operating system on a BE from a flash archive. You can perform the same function with luupgrade(1M).
Displays help information. There are also context-specific help screens for many of the options.
You navigate through lu's various screens using arrow keys and function keys (usually F2 through F9 on the keyboard of a Sun desktop system). Available key functions are displayed at the base of the lu screen. You can use Ctrl-F, plus a number key, to duplicate a function key. For example, press Ctrl-F and the number key 2 to duplicate the F2 key.
In a screen for a given option, you can press Esc to obtain context-specific help.
When viewing the FMLI interface remotely, such as over a tip line, you might need to set the TERM environment variable to VT220. When using the FMLI interface in a CDE environment use dtterm, rather than xterm, as the value of the TERM variable.
The lu command supports only single-byte environments.
Most of the options listed above offer the following functions. These functions are accessible through function keys indicated at the base of the screen.
Available to you whenever you have a field that can be filled in. Pressing the Choice function key gives you a popup screen displaying a list of alternatives. For example, for options involving copying or upgrading BEs, you receive a list of available BEs. You can then use arrow and function keys to make a selection from this popup. The choice function is useful because it prevents you from selecting an invalid alternative. In our example, it prevents you from choosing a BE that is not available for a copy or upgrade operation. Such non-availability might occur when a BE is in the midst of an upgrade.
Cancel an operation.
Proceed with an operation.
The “Create” option, described above, offers the following functions:
Split a file system. For example, you can split a / file system into /, /usr, and /var. To split a file system, you must have disk slices available on which to mount the separated file system(s). If you do not, lu invokes the format(1M) utility, in which you can use the partition option to create a new disk slice.
Join one or more file systems with its (or their) parent file system. For example, using a source BE that has separate /, /usr, and /var file systems, you can merge these file systems under / on a target BE.
list of BEs on the system
See attributes(5) for descriptions of the following attributes:
luactivate(1M), lucancel(1M), lucompare(1M), lucreate(1M), lucurr(1M), ludelete(1M), ludesc(1M), lufslist(1M), lumake(1M), lumount(1M), lurename(1M), lustatus(1M), luupgrade(1M), lutab(4), attributes(5), live_upgrade(5)
Solaris Installation Guide
The lu command is a deprecated interface. See DESCRIPTION.