|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- identify users of files and devices
/usr/sbin/fuser [-c | -d | -f] [-nu] [-k | -s sig] files [ [-] [-c | -d | -f] [-nu] [-k | -s sig] files] ...
The fuser utility displays the process IDs of the processes that are using the files specified as arguments.
Each process ID is followed by a letter code. These letter codes are interpreted as follows. If the process is using the file as
Indicates that the process is using the file as its current directory.
Indicates that the process is holding a non-blocking mandatory lock on the file.
Indicates that the process is using the file as an open file.
Indicates that the process is using the file as its root directory.
Indicates that the process is using the file as its text file.
Indicates that the process is using the file as its controlling terminal.
For block special devices with mounted file systems, all processes using any file on that device are listed. For all types of files (text files, executables, directories, devices, and so forth), only the processes using that file are reported.
For all types of devices, fuser also displays any known kernel consumers that have the device open. Kernel consumers are displayed in one of the following formats:
[module_name] [module_name,dev_path=path] [module_name,dev=(major,minor)] [module_name,dev=(major,minor),dev_path=path]
If more than one group of files are specified, the options may be respecified for each additional group of files. A lone dash cancels the options currently in force.
The process IDs are printed as a single line on the standard output, separated by spaces. All other output, including the single terminating newline, is written on standard error.
Any user can run fuser, but only the superuser can terminate another user's process.
The following options are supported:
Reports on files that are mount points for file systems, and any files within that mounted file system.
Report device usage information for all minor nodes bound to the same device node as the specified minor node. This option does not report file usage for files within a mounted file system.
Prints a report for the named file, not for files within a mounted file system.
Sends the SIGKILL signal to each process. Since this option spawns kills for each process, the kill messages may not show up immediately (see kill(2)). No signals will be sent to kernel file consumers.
Lists only processes with non-blocking mandatory locks on a file.
Sends a signal to each process. The sig option argument specifies one of the symbolic names defined in the <signal.h> header, or a decimal integer signal number. If sig is a symbolic name, it is recognized in a case-independent fashion, without the SIG prefix. The -k option is equivalent to -s KILL or -s 9. No signals will be sent to kernel file consumers.
Displays the user login name in parentheses following the process ID.
Example 1 Reporting on the Mount Point and Files
The following example reports on the mount point and files within the mounted file system.
example% fuser -c /export/foo
Example 2 Restricting Output when Reporting on the Mount Point and Files
The following example reports on the mount point and files within the mounted file system, but the output is restricted to processes that hold non-blocking mandatory locks.
example% fuser -cn /export/foo
Example 3 Sending SIGTERM to Processes Holding a Non-blocking Mandatory Lock
The following command sends SIGTERM to any processes that hold a non-blocking mandatory lock on file /export/foo/my_file.
example% fuser -fn -s term /export/foo/my_file
See environ(5) for descriptions of the following environment variables that affect the execution of fuser: LANG, LC_ALL LC_CTYPE, LC_MESSAGES, and NLSPATH.
See attributes(5) for descriptions of the following attributes:
Because fuser works with a snapshot of the system image, it may miss processes that begin using a file while fuser is running. Also, processes reported as using a file may have stopped using it while fuser was running. These factors should discourage the use of the -k option.